PolyWorks® V10
Beginner’s Guide

February 2007

✓ IMAlign™
✓ IMEdit™
✓ IMInspect™
✓ IMMerge™
✓ IMView™

InnovMetric Software Inc.
2014 Cyrille-Duquet, Suite 310
Québec, Québec, Canada, G1N 4N6
Tel.: (418) 688-2061 Fax: (418) 688-3001
Contents

Introduction .................................................................................................................. 7

Your Beginner’s Guide ............................................................................................................ 7
For more information ................................................................................................................. 7
Before you start .............................................................................................................. 7
Getting the data files ................................................................................................................. 8
Typical PolyWorks Workflow .................................................................................................. 10

PolyWorks Basics ............................................................................................................. 11

1. The PolyWorks/Workspace Manager ........................................................................ 11
   1.1 The Workspace Manager interface ........................................................................ 12
   1.2 The Wizard window .............................................................................................. 13
   1.3 Workspace contents .............................................................................................. 14
   1.4 Sharing a PolyWorks workspace ............................................................................ 14

2. Interface Basics ........................................................................................................... 15
   2.1 Getting ready .......................................................................................................... 15
   2.2 Visiting a module interface .................................................................................... 15
   2.3 Working in the 3D scene ....................................................................................... 19
   2.4 Working with objects ............................................................................................. 21
   2.5 Objects and their elements ..................................................................................... 22
   2.6 Additional information ......................................................................................... 24
   2.7 End the exercise ..................................................................................................... 24
   2.8 Close the active PolyWorks workspace ............................................................... 24
   2.9 Exit the Workspace Manager ................................................................................ 24
Acquiring Data ........................................................................................................ 25

A. Scan the part ................................................................................................. 26

B. Align the scans ........................................................................................... 27
   IMAlign basics ................................................................................................. 27
   Exercise #1: A typical alignment project...................................................... 28
      1. Get ready.......................................................................................... 29
      2. Import and align 3D Images one at a time............................................ 30
      3. Optimize the global 3D Image alignment.............................................. 34
      4. Analyze the quality of the alignment.................................................... 35
      5. Save and exit.................................................................................... 37
   Exercise #2: Auto-align 3D Images............................................................... 38
      1. Get ready.......................................................................................... 38
      2. Import and automatically align 3D Images one at a time........... 38

Reverse Engineering ..................................................................................... 41

A. Generate a polygonal model ..................................................................... 43
   IMMerge basics ............................................................................................ 43
   Exercise #1: Generate a polygonal model.................................................... 44
      1. Start IMMerge................................................................................ 44
      2. Set parameters............................................................................. 44
      3. Start the merging process ............................................................. 44
      4. Exit IMMerge ............................................................................. 44
   Additional information................................................................................. 45

B. Improve the polygonal model .................................................................... 46
   IMEdit basics ............................................................................................... 46
   Exercise #1: A typical editing project.......................................................... 48
      1. Get ready........................................................................................ 49
      2. Import the polygonal model............................................................. 49
      3. Edit the model.............................................................................. 50
         3.1 Fill holes........................................................................... 50
         3.2 Smooth vertices.......................................................... 54
         3.3 Extract sharp edges..................................................... 55
      4. Optimize the polygonal mesh............................................................ 56
         4.1 Optimize the mesh........................................................ 56
4.2 Reduce the mesh………………………………………. 57
5. Extract the shape of the model……………………………. 58
6. Export the edited polygonal model…………………………. 59
7. Save the IMEdit editing project…………………………….. 59

C. Create NURBS surfaces ………………………………………… 60

Exercise #1: Create NURBS surfaces - manual method…………. 61
1. Get ready…………………………………………………… 62
2. Extract feature curves……………………………………….. 62
3. Complete the curve set……………………………………… 66
4. Create the curve network …………………………………… 70
5. Fit NURBS surfaces on the model using the curve network….. 70
6. Export the fitted NURBS surfaces…………………………. 71
7. Save the IMEdit editing project and exit …………………… 71

Exercise #2: Create NURBS surfaces - automatic method………… 72
1. Get ready…………………………………………………… 72
2. Extract feature curves……………………………………….. 72
3. Perform the auto-nurbing…………………………………… 73
4. Save the IMEdit editing project and exit …………………… 74

Inspection…………………………………………………………. 75

A. Inspect the digitized part ……………………………………… 77

IMInspect basics……………………………………………….. 77

Exercise #1: A typical inspection project………………………. 79
1. Get ready…………………………………………………… 80
2. Define the Reference object………………………………… 81
   2.1 Import the Reference object ............................. 81
   2.2 Create Features on the Reference object............ 82
3. Acquire the Data object ……………………………………. 83
4. Align the Data object to the Reference object …………….. 83
   4.1 Pre-align using a best-fit alignment ………………… 83
   4.2 Auto-extract measured Primitives on the Data object.. 84
   4.3 Align using Features………………………………… 84
5. Measure ……………………………………………………... 85
   5.1 Compare using all data points ……………………… 85
   5.2 Compare using Cross-Sections……………………. 86
   5.3 Take basic measurements…………………………….. 89
6. Report results ………………………………………………. 90
7. Save the inspection project and exit .............................................. 90

Exercise #2: Control Feature Dimensions and GD&T ...................... 91
1. Get ready .................................................................................. 91
2. Create the Features ................................................................. 92
3. Control dimensions ................................................................. 93
4. Perform GD&T controls ............................................................. 94
5. Save and exit .......................................................................... 95

Exercise #3: Using an automated inspection project ......................... 96
1. Get ready ................................................................................ 96
2. Perform the automatic operations ............................................ 97

B. Share the results ........................................................................ 98

IMView basics ............................................................................... 99

Exercise #1: View an inspection project ........................................... 100
1. View the categories of objects and their comparison results ........ 100
2. Take new measurements .......................................................... 100
3. Create new report items .......................................................... 101
4. Create a new formatted report ................................................ 101
5. Export objects ....................................................................... 104
6. Exit IMView ........................................................................ 104

Additional Information .................................................................. 105

1. IMAlign – More information and other tools ............................. 105
2. IMEdit – Other tools ............................................................... 107
3. IMEdit – IMCompress parameters ............................................ 111
4. IMInspect – Macro script basics .............................................. 112
5. IMInspect – Other tools ......................................................... 115
InnovMetric Software Inc. welcomes you to PolyWorks®, the leading software in the world for reverse-engineering and inspection applications using high-density point clouds.

Your Beginner’s Guide...

The PolyWorks V10 Beginner’s Guide will walk you through a typical reverse-engineering process and a typical inspection process using PolyWorks V10. You will learn basic notions and do exercises that result in a reverse-engineering and an inspection application. This guide:

• Is goal oriented - we provide you with the procedures, parameter values, and data files and you do the work.

• Uses workflow charts and a step-by-step approach; the workflow charts can be used as a general summary of all the steps needed to accomplish a basic inspection or reverse-engineering project in PolyWorks.

• References other PolyWorks tools not seen in this guide to round up your learning experience.

In order to use this guide and do the exercises, the PolyWorks software must be installed and the license keys obtained that activate the software.

For more information...

You will learn quickly, and want to know more about certain tools or parameters, or have questions about tools not demonstrated in this guide. You can continue your learning by referring to the PolyWorks reference guides, by accessing the tutorials and the case studies available on our web site, by contacting your technical support service, or by following a training tailored to your needs.

Before you start...

You will benefit from:

• Instructions for getting the data files required for the exercises on page 8.

• A global PolyWorks workflow presentation on page 10.
Getting the data files

The goal of this Beginner's Guide is to learn through practical exercises, using prepared data files (scans, polygonal models, etc.). The data files are available on CD or online. The procedures that follow explain how to copy these files to your computer's local disk. On the next page, you will find a brief description of the files provided.

1 - On the PolyWorks Installation CD-ROM

- Insert the PolyWorks V10 installation CD-ROM in your CD drive.
- Cancel the installation that is launched automatically.
- Open Windows Explorer or My Computer.
- Click on the CD drive.
- Copy the PolyWorks V10 Beginner's Guide Data directory to your computer's local disk.
- Right-click on the copied directory and choose Properties. A dialog box pops up.
- Uncheck the Read-only attribute and click OK. A dialog box pops up.
- Check Apply changes to this folder, subfolders and files, and click OK.

2 - On the Technical Support Zone of our web site:

- Start your web browser.
- If the web site language is not English, click on the English link at the top of the web page.
- Find the TECHNICAL SUPPORT ZONE title on the page (see figure to the right).
- Enter your login and password, and click Enter. If you don’t have your own login, you can use the public one:
  - Login: polyworks
  - Password: accurate
    - Click Data Exchange.
    - In the Data Exchange section, under Public, click PolyWorks V10 Beginner’s Guide Data to download to your computer’s local disk.
    - Select the directory PolyWorks V10 Beginner's Guide Data.
    - Right-click and choose Properties. A dialog box pops up.
    - If the Read-only attribute is set, unset it and click OK. A dialog box pops up.
    - Check Apply changes to this folder, subfolders and files and click OK.

See the next page for the PolyWorks V10 Beginner’s Guide Data directory structure and the names of the data files. In the exercises that will follow, only the file names will be provided.
The PolyWorks V10 Beginner's Guide Data directory structure and data files:

**PolyWorks V10 Beginner's Guide Data**

- **PolyWorks Workspaces**
  - PolyWorks_interfaces.pwk.pwzip
  - PolyWorks_processes.pwk.pwzip

  Two PolyWorks workspaces, containing files required for exercises, in a compressed format (.pwzip). They will be decompressed when you open them in the PolyWorks/Workspace Manager.

- **Reference Object**
  - IMBlock_CAD.igs

  The theoretical CAD model for the inspection exercise.

- **Scans of IMBase**
  - IMBase_1.pf
  - IMBase_2.pf
  - IMBase_3.pf
  - IMBase_4.pf
  - IMBase_5.pf
  - IMBase_6.pf
  - IMBase_7.pf
  - IMBase_8.pf

  Raw scan files of a base. For the alignment exercise.

- **Scans for Auto-align**
  - Sheetmetal_001.pf
  - Sheetmetal_002.pf
  - Sheetmetal_003.pf
  - Sheetmetal_004.pf
  - Sheetmetal_005.pf
  - Sheetmetal_006.pf

  Raw scan files of a sheet metal part for the auto-alignment exercise.
Typical PolyWorks Workflow

PolyWorks is the leading reverse-engineering and inspection software solution on the market today. The PolyWorks process consists of three sub-processes, as shown in the workflow below:

- **Acquiring Data** - You either have point clouds or can scan a part using your digitizer and PolyWorks plug-ins. Then, align the point clouds accurately, or if your point clouds are already aligned, verify the alignment quality prior to reverse engineering or inspection.

- **Reverse Engineering** - Generate a high-quality polygonal model from the aligned point clouds, then improve the polygonal model to meet your downstream application requirements, and even create high-quality NURBS surfaces.

- **Inspection** - Compare the aligned point clouds to a reference object using user-defined tolerances. Take accurate measurements. Create customized reports. Then, send the results to your partners for viewing with the free PolyWorks inspection project viewer.

This guide is built around this simple workflow. While the next section quickly presents the PolyWorks/Workspace Manager and PolyWorks interface basics, the three most important sections introduce the processes described above.
The PolyWorks/Workspace Manager

PolyWorks Basics

In PolyWorks Basics, you will first become familiar with the PolyWorks/Workspace Manager (WM). This tool lets you use the PolyWorks modules and manages workspaces that contain your files and the IMAlign, IMEdit, and IMInspect Projects that you create using PolyWorks. The second part of PolyWorks Basics lets you become familiar with the PolyWorks graphical user interface. The content is part information and part exercise.

1. The PolyWorks/Workspace Manager

This section describes the PolyWorks/Workspace Manager. It is always open when you work with PolyWorks. It stores the files that you use and create in a PolyWorks workspace. The instructions that follow explain how to open the Workspace Manager and open a PolyWorks workspace. The workspace contains two objects that will be used to explore interface basics.

IMPORTANT: If you have already copied the data files to your hard disk, as explained on page 8, go to the next step. If you have not copied the files, please go to page 8 and follow the procedure. The directory that contains the data files should be named PolyWorks V10 Beginner’s Guide Data.

Get Ready

1. Open the PolyWorks/Workspace Manager – double-click on the PolyWorks shortcut on your Windows desktop.
2. Click Cancel in the popup dialog box.
4. Set Default workspace directory to the PolyWorks V10 Beginner’s Guide Data\PolyWorks Workspaces directory on your hard disk. Press the ellipsis button to pop up a browser.
5. Click OK.
7. Select PolyWorks_Interfaces.pwk.pwzip, and click Open.
8. A browser pops up. Specify a directory to which the workspace should be extracted.
9. Click OK.

The Workspace Manager is open. The Workspaces area displays the names of open PolyWorks workspaces and shows the contents of the active PolyWorks workspace. The active workspace contains two objects:

| Workspaces | IMEdit_project | An IMEdit Project containing three polygonal models. This object can be opened by the IMEdit module. |
|PolyWorks_Interfaces | IMInspect_project | An IMInspect Project containing three digitized parts. This object can be opened by the IMInspect module. |

PolyWorks V10 Beginner’s Guide
1.1 The Workspace Manager interface

The Workspace Manager’s user interface features:

- A **Menu Bar**.

- The **Standard Toolbar** that features the PolyWorks modules, as well as shortcuts to the Add Key wizard and the Windows command prompt.

- A **Workspaces** area to the left that contains open workspaces, only one of which can be active at a time. The contents of the active workspace are displayed using an object tree, while open modules using workspace objects are indicated below the object tree.

- A **Wizard** window to the right that displays processing options/properties for the selected object.

The Workspace Manager lets you open multiple workspaces. Click on a workspace name in the **Workspaces** area to make it active and see its contents. Click on an object in the active workspace object tree and see its properties, possible next steps (processing), and notes in the **Wizard** window. You can access a shortcut menu for each object by right-clicking over the object (see the PolyWorks Reference Guide).
In the figure below, the PolyWorks modules are classified by process and type of interface:

1.2 The Wizard window

The Wizard window contains information on the object selected in the active workspace, proposes possible next steps for processing the object, and displays the object’s notes, if any. The notes may be added to the object by the user and notes may also be added by certain operations.
1.3 Workspace contents

A PolyWorks workspace is where the files that you input into a PolyWorks module and files normally output by a PolyWorks module, either on exiting the module or using the File > Save command, are stored. File management is that easy. The table that follows shows the input for a PolyWorks module and its output. As you work through the exercises in this guide, you will see objects added to the active workspace.

<table>
<thead>
<tr>
<th>Input</th>
<th>Module</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Workspaces</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Untitled</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IMAAlign Projects</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Polygonal Models</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IMEdit Projects</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IMInspect Projects</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IMTexture Input Files</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3D Digitized Datasets</td>
</tr>
</tbody>
</table>

1.4 Sharing a PolyWorks workspace

A PolyWorks workspace is represented by two items on your hard disk:

<table>
<thead>
<tr>
<th>WorkspaceName.pwk</th>
<th>WorkspaceName_Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workspace 4.pwk</td>
<td>Workspace 4_Files</td>
</tr>
</tbody>
</table>

An XML file that contains a description of the PolyWorks workspace contents and the dependencies between objects and modules.

A directory that contains all of the objects present in the PolyWorks workspace, with the exception of 3D digitized datasets imported using the Keep files external to workspace option, or polygonal models imported using the IMAlign module and using the same import parameter.

It is easy to send a workspace to a colleague as one file. Use the File > Export Compressed Workspace command. The XML file and the object directory are zipped to one single file. If any objects were imported using the Keep files external to workspace option, they are automatically added to the compressed workspace. Your colleague can open the zipped workspace directly in the Workspace Manager.
2. Interface Basics

The main modules, IMAlign, IMEdit, IMInspect, and IMView all have similar graphical user interfaces. This section will help you become familiar with the interface by presenting items that are common to all modules. The specifics of each module are presented in later sections.

The content here is part explanation, part exercise. The active workspace contains an IMEdit Project and an IMInspect Project. You will open one project. It will serve as a learning tool.

2.1 Getting ready

- Specify a visual layout. From the Workspace Manager main menu: Window > Visual Layout > Manufacturing - Beginner.

- Open an IMEdit Project or an IMInspect Project for demo purposes. Do one of the two instructions that follow:
  - **IMEdit**: In the IMEdit Projects branch of the active workspace, select `IMEdit_project` and click “Open the IMEdit project” in the Wizard window. The IMEdit module opens.
  - **IMInspect**: In the IMInspect Projects branch of the active workspace object tree, select `IMInspect_project` and click “Open the IMInspect project” in the Wizard window. The IMInspect module opens.

2.2 Visiting a module interface

2.2.1 The basic layout

The graphical user interfaces all have the same items in their default layout. The position of the main windows may be changed by the user.
2.2.2 The Menu bar

The Menu bar offers all of the main module operations. Menu items in the center are specific to the module and represent the major classes of operations. Frequently used menu items have keyboard shortcuts, and any item can be assigned to the customized toolbar. Note that menu items available for each menu vary according to the specified visual layout.

![Menu bar diagram]

2.2.3 The Tree View

The Tree View is an object management center. Each object has a name and an icon, and in some modules an index number (IMAlign and IMInspect). The icon represents the type of object. Its representation changes to show the current status of the object (ex. locked).

The Tree View also offers shortcut menus. Let’s consider a branch and an object shortcut menu in IMEdit.

Right-clicking on a branch pops up a shortcut menu that offers creation and importing operations (Create and Import menus) that are specific to the object category. The last item offers menu items from parent branches, if any.

Right-clicking on an object pops up a shortcut menu that offers exporting and object-editing operations (Export and Edit menus) specific to the object type. The last section offers menu items from parent branches, if any.
2.2.4 Packaged toolbars

PolyWorks modules are delivered with a number of toolbars. Right-click in the menu area to display the toolbar list and show/hide specific toolbars. PolyWorks is entirely configurable – this includes all menu items and toolbars.

<table>
<thead>
<tr>
<th>The Standard toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generic toolbar common to all modules. It provides a quick access to the most frequently used functions of the Menu Bar. As an indication, the <em>File</em> operations as well as the selection settings are part of its contents. See below IMInspect’s <em>Standard</em> toolbar.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>The Main Objects toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>The <em>Main Objects</em> Toolbar (not available in IMAlign) offers a quick access to the creation and the editing operations grouped by category of object. It provides access to all the related operations in the Menu Bar as well as more minor editing operations only found in this toolbar. See below IMInspect’s <em>Main Objects</em> toolbar.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>“Module-specific” toolbars</th>
</tr>
</thead>
<tbody>
<tr>
<td>The “module-specific” toolbars offer a group of tools, that are sparse in the menus, to achieve a specific task. See below IMEdit’s <em>Polygonal Edition</em> toolbar and IMInspect’s <em>Main Process</em> toolbar.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>The 3D Scene toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>The 3D Scene toolbar is common to all modules. It provides shortcuts to the most-used functions of the <em>View</em> main menu.</td>
</tr>
</tbody>
</table>

2.2.5 The Dialog Zone

The *Dialog Zone* window is an area dedicated to the display of dialog boxes, including object property sheets and contextual parameter dialog boxes. Several dialog boxes may be present, each one accessible by its tab (see the figure to the right).

If a particular dialog box is not completely visible in the Dialog Zone, it can be displaced within the zone by middle-clicking and dragging. Or, you may choose to simply enlarge the Dialog Zone by dragging a side.
2.2.6 Showing/hiding parameter dialog boxes

For some operations, a special contextual parameters dialog box is displayed in the Dialog Zone to help new users. These windows can be closed by checking the Do not show this window check box. To make the window display again, press the Contextual Parameters icon on the Standard toolbar.

Exercise

1. Press the Select button.
2. Press the Show/Hide Contextual Parameters button to enable/disable the display of the help window.
3. Press ESC to exit Selection mode.

2.2.7 Important keys/mouse buttons

The following keys are used in all of the modules:

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESC</td>
<td>exits the current operation mode</td>
</tr>
<tr>
<td>SPACEBAR</td>
<td>• enters Selection mode if not already in another mode</td>
</tr>
<tr>
<td></td>
<td>• enters Interrupt mode to move objects in the 3D scene if the current mode permits it</td>
</tr>
</tbody>
</table>

The following mouse operation is available in all of the modules:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>middle-click on an object in the object tree</td>
<td>toggles the visibility status (show/hide) of the object</td>
</tr>
</tbody>
</table>
2.3 Working in the 3D scene

2.3.1 Moving the 3D scene

The 3D scene may be moved (transformed) along the $x$, $y$, $z$ viewing axes using mouse-based operations. When you open a module, the toolbar shown below is displayed in the Dialog Zone to help you learn to move the 3D scene. A learning mode and an expert mode are offered. It is important to master these operations as they are used often.

The last five buttons represent the learning mode. Press one of these buttons and all of your mouse buttons will do only the action of that button. See the figure to the left below. To be able to use all of the operations at any time, the expert mode, press the first button. Now, you must specify the operation by pressing the correct mouse button and you may need to press and hold down the SHIFT key. The mouse buttons and keys to use for each operation are shown as icons in the dialog box. For example, to translate the 3D scene, hold down the middle mouse button while moving the mouse.

Additional Information

- 3D rotation operation: make sure you pick on an object (center of rotation); if you pick on a background pixel, the center of the bounding box is used as center of rotation.

- 3D rotation operation (variation): hold down the SHIFT key and move the mouse – if the first 10-pixel displacement is in a vertical direction, the rotation is about the horizontal axis of the 3D scene, and if it is in a horizontal direction, the rotation is about the vertical axis of the 3D scene.

- Rotate about view axis operation (variation): instead of moving the mouse with the SHIFT key and the right mouse button held down, simply hold down the SHIFT key and click the right mouse button – the 3D scene will rotate around the viewing axis by increments of 90 degrees.
2.3.2 Interrupt a mode to move objects in the 3D scene

When you are in an interactive mode, let’s say picking a curve or a polyline, you may have to move the object in order to continue working. This is possible by interrupting the interactive mode. The Interrupt mode is enabled and exited by pressing the SPACEBAR. You will use the Interrupt mode often in this guide so it is essential to master it.

Do only one of the two exercises below.

In the exercise you will create a plane by picking 3 points on objects. Imagine that the third point to pick is not visible given the current position of the objects in the 3D scene. You will first pick two visible points and then use the Interrupt mode to interrupt the picking, move the 3D scene to a desired position, re-enter the picking mode, and pick the last point.

**Exercise if you are using the IMEdit Project**

1. On the Main Objects toolbar of the IMEdit module, click the *Plane Creation and Editing* button.
2. Click the *Create Plane from 3 Picked Points* button.
3. Pick two points on an object surface.
4. Press the SPACEBAR to go to Interrupt mode.
5. Move the object to better orient the object with respect to the third point to pick.
6. Press the SPACEBAR to exit Interrupt mode.
7. Pick the third point on a object surface. A Plane is created.
8. Press the ESC key to exit the interactive creation mode.

**Exercise if you are using the IMInspect Project**

In this exercise a dialog box will be displayed in the Dialog Zone. If it is not entirely visible, you may choose to enlarge the Dialog Zone, or simply displace the dialog box in the Dialog Zone by middle-clicking on it and dragging.

1. On the Main Objects toolbar of the IMInspect module, click the *Feature Creation* button.
2. Click the *Create Plane Feature* button. A dialog box appears (Dialog Zone).
3. Set *Method* to *Anchor*.
4. Click the *Anchor* button.
5. Pick two points on an object.
6. Press the SPACEBAR to go to Interrupt mode.
7. Move the object to better orient the object with respect to the third point to pick.
8. Press the SPACEBAR to exit Interrupt mode.
9. Pick the third point on an object. A Plane Feature is created.
10. Press the ESC key to exit the interactive creation mode.

**Important:** The 3D Scene window must have the focus before the SPACEBAR is pressed to enter Interrupt mode. The 3D Scene window will already have the focus if you are working in it, for example picking points. If this is not the case, the focus can be given to the 3D Scene window by clicking its title bar or by moving the cursor rapidly into the 3D Scene window.
2.4 Working with objects

PolyWorks modules import basic objects and process them for results.

<table>
<thead>
<tr>
<th>IMAlign</th>
<th>IMEdit</th>
<th>IMInspect</th>
</tr>
</thead>
</table>
| 3D Images (created from imported scans) | polygonal models | • digitized parts = 3D digitized datasets and polygonal models  
• theoretical models = CAD and polygonal models, and 3D digitized datasets (planar grid/mesh) |

Processing these objects creates other objects. Commands let you select and manipulate the objects.

2.4.1 Selecting objects

- To select all objects in the object tree: Select > Objects > All.
- To select individual objects in the object tree, use standard Windows-based selection techniques.
- To select objects in the 3D scene, press the Select Objects button on the Standard toolbar and either click on objects (hold down the CTRL key to add to the current selection), or middle-click and drag to select all objects within the selection rectangle.

2.4.2 Manipulating objects

Frequent manipulations include hiding, ignoring (ignored by operations), or locking (position) objects. The status of the object is represented by the object’s icon.

<table>
<thead>
<tr>
<th>Action</th>
<th>Command in the shortcut menu (right-click on object)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visibility</td>
<td></td>
</tr>
<tr>
<td>Hide</td>
<td>View &gt; Hide</td>
</tr>
<tr>
<td>Restore</td>
<td>View &gt; Restore</td>
</tr>
<tr>
<td>Keep (and hide all others)</td>
<td>View &gt; Keep</td>
</tr>
<tr>
<td>Shortcut: Hide/Restore 1 object</td>
<td>just middle-click on object in the object tree</td>
</tr>
<tr>
<td>Availability</td>
<td></td>
</tr>
<tr>
<td>Ignore</td>
<td>Edit &gt; Ignore (Object)</td>
</tr>
<tr>
<td>Use</td>
<td>Edit &gt; Use (Object)</td>
</tr>
<tr>
<td>Position</td>
<td></td>
</tr>
<tr>
<td>Lock</td>
<td>Edit &gt; Lock</td>
</tr>
<tr>
<td>Unlock</td>
<td>Edit &gt; Unlock</td>
</tr>
<tr>
<td>* IMAlign and IMInspect</td>
<td></td>
</tr>
</tbody>
</table>
2.5 Objects and their elements

Elements are what make up objects. Main objects all have elements.

<table>
<thead>
<tr>
<th></th>
<th>IMAlign</th>
<th>IMEdit</th>
<th>IMInspect</th>
</tr>
</thead>
<tbody>
<tr>
<td>main objects</td>
<td>3D Images</td>
<td>polygonal models</td>
<td>point clouds, polygonal models, CAD models</td>
</tr>
<tr>
<td>elements</td>
<td>3D Image points</td>
<td>vertices and triangles</td>
<td>points of point clouds, points (vertices) of polygonal models, NURBS surfaces of CAD models</td>
</tr>
</tbody>
</table>

Some important secondary objects (like Cross-Sections) also have object elements. Some operations require selecting and hiding or deleting object elements.

2.5.1 Selecting object elements

PolyWorks features selection operations that apply to object elements. This section gives a general explanation. Comments for specific modules will be given when appropriate.

Configuring the selection mode

You must first specify the selection mode. This can be done through Select menu items or their toolbar equivalents:

- You can choose to Mark or Unmark selected elements, or to Toggle their current selection status.
- If the elements include triangles, you can specify to select Front-facing only, Back-facing only (dark color), or both Front and Back-facing; this applies only to surface-based region selections, as volume-based surface selections always select both front- and back-facing triangles.
Selecting the object elements

Selecting elements can be done using Select menu items, or interactively in Selection mode. The second method is described here. Enter Selection mode by pressing the Select Elements button in the Standard toolbar, or by pressing the SPACEBAR.

On entering Selection mode, the Selection Context dialog box pops up. The top part lets you specify the elements to select, and the bottom part is for configuring the Selection mode (explained on the previous page).

Two items concern region-based selections (that use a selection contour):

- Selection type: by default, the selection is surfacic. For a volumetric selection, press and hold down the SHIFT key.
- Selection contour: by default, the selection contour is freeform – drag a selection contour using the middle-mouse button. To obtain a polygonal selection contour, press and hold down the CTRL key while middle-clicking, and right-click to close the contour.

See the two region-based selections demonstrated in the table below.

<table>
<thead>
<tr>
<th>Contour</th>
<th>Selected elements</th>
</tr>
</thead>
<tbody>
<tr>
<td>a surfacic selection using a freeform contour</td>
<td><img src="image1.png" alt="Surfacing Selection" /> = <img src="image2.png" alt="Selected Elements" /></td>
</tr>
<tr>
<td>a volumetric selection using a polygonal contour</td>
<td><img src="image3.png" alt="Volumetric Selection" /> = <img src="image4.png" alt="Selected Elements" /></td>
</tr>
</tbody>
</table>
2.6 Additional information

Several sources of information are available.

<table>
<thead>
<tr>
<th>Location</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>• in a module, select Help &gt; “Name of module” Reference Guide</td>
<td>each module’s complete reference documentation in PDF format; for example, IMEdit Reference Guide</td>
</tr>
<tr>
<td>• in the Workspace Manager, select Help &gt; Reference Guides &gt; “Name of module”</td>
<td></td>
</tr>
</tbody>
</table>
| related documentation in the Documentation subdirectory of the PolyWorks installation directory (PDF format) | • PolyWorks Reference Guide  
• Macro and SDK Reference Guide  
• user guides for plug-ins with a complete description of dialog box items |
| InnovMetric Software Web site www.innovmetric.com                        | • tutorials (text and video)  
• FAQs  
• case studies |

2.7 End the exercise

2. Click No.  

Control returns to the Workspace Manager.

2.8 Close the active PolyWorks workspace

• Menu: File > Close.

2.9 Exit the Workspace Manager

• Menu: File > Exit.
Acquiring Data

Objective

PolyWorks enables reverse-engineering and inspection applications using high-density point clouds. Acquiring data is the first item in the PolyWorks workflow (see page 10). It consists of two steps.

<table>
<thead>
<tr>
<th>Step</th>
<th>Illustration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A. Scan the part</strong></td>
<td>The part is represented by several scans, each in its own coordinate system.</td>
</tr>
<tr>
<td>Import scans from any digitizer in PolyWorks. Plug-ins are also provided to scan directly within PolyWorks.</td>
<td></td>
</tr>
<tr>
<td><strong>B. Align the scans</strong></td>
<td>The 3D Images are positioned accurately with respect to neighboring 3D Images, reconstituting the part; all 3D Images are now in the same global coordinate system.</td>
</tr>
<tr>
<td>Use <strong>IMAlign</strong> to create 3D Images (PolyWorks format) from scans from any 3D digitizer, and align the 3D Images quickly and accurately.</td>
<td></td>
</tr>
<tr>
<td>If you have scans that are already aligned, you can use IMAlign to verify/improve the scan alignment prior to reverse-engineering or inspection of the digitized part.</td>
<td></td>
</tr>
</tbody>
</table>
A. Scan the part

The digitizing process uses a 3D digitizer to capture points that represent the surface of an object. The resulting point clouds are an exact representation of the physical object.

There are a wide variety of 3D digitizers, and PolyWorks supports all of them:

- **Plug-ins**: some 3D digitizers are supported through plug-ins, so users can connect the digitizer hardware to the workstation running PolyWorks and scan the object directly in the PolyWorks interface.
- **Native file import**: for other supported 3D digitizers, PolyWorks can read the native file format created by the digitizer application.
- **Neutral file import**: for all other 3D digitizers, PolyWorks can read the point clouds using one of the standard point cloud file formats, such as `txt` or `iges`.

In the Beginner’s Guide, we will be working with *Planar Grid/Mesh* 3D digitized datasets. Eight scans were necessary to capture the object, which is the base in the photo below, and each scan is in its own coordinate system.

The next step shows you how to align all the scans together in a global coordinate system.
B. Align the scans

IMAlign basics

Position all of your scans in the same coordinate system, based on the shape of the scanned object. For proper alignment, your scans must meet two criteria: each scan must share some overlapping areas with adjacent scans, and each scan should contain at least one change of shape (e.g., corner, hole, angle) of the object, since IMAlign performs a shape-based alignment (changes in shape help lock the scans).

IMAlign can work with hundreds of scans from any digitizer. It is even possible to combine scans of a part produced by different digitizers.

IMAlign converts the scanned data into a perfectly gridded 3D Image using an interpolation process. This creation process is performed at the file importing stage. During file importation, there is a specific conversion process for each category of digitizer. This exercise uses a digitizer point cloud category called Planar Grids/Meshes – the 3D Image-from-scan creation is completely automatic during file loading.

The basic interface layout

The default IMAlign interface layout features the Tree View window, the Dialog Zone window, and the 3D Scene window. The Processes toolbar, that will be used often in the exercises to follow, is indicated below.
Exercise #1: A typical alignment project

Objective

In this exercise, you will be guided through the typical process of aligning scans using the IMAlign module.

Eight scans have been provided for you. Each one is in its own coordinate system. The objective in IMAlign is to accurately align the scans to each other, in one global coordinate system.

The scans must meet the following requirement:

- Overlap: each scan must share some overlap with at least one other scan; this is required since a sufficient number of points is needed to describe the part and also because those common features are used to properly position each 3D Image relative to the others.

Typical workflow

Data files

- If you have copied the data files to your hard disk, as explained on page 8, go to the next step. If you have not copied the files, please go to page 8 and follow the procedure. The directory that contains the data files should be named PolyWorks V10 Beginner’s Guide Data.
1. Get ready

- 1. Open the PolyWorks/Workspace Manager by double-clicking on the PolyWorks shortcut on your Windows desktop. The Workspace Manager pops up.
- 2. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
- 3. Click the ellipsis button ( ) in the Create new workspace area of the Open or Create Workspace window to create a new workspace. A browser pops up.
- 4. Specify a workspace name and location and click Save.
- 5. Click Create.

Start the IMAlign module

- 1. In the PolyWorks/Workspace Manager, click on the IMAlign button in the Standard toolbar. The IMAlign module starts.

Configure the file/directory browsers

The path specified will be used to read/write standalone files (not found in a workspace).

- 1. Menu: Config > Browsers. A dialog box pops up.
- 3. Click Browse and specify the directory where the scans are stored: PolyWorks V10 Beginner’s Guide Data\Scans of IMBase.
- 4. Click OK.

Choose a digitizer

When a digitizer is chosen, IMAlign sets default parameters optimized for the specified digitizer.

- 1. Menu: Config > Digitizers. A dialog box pops up.
- 2. Set Digitizer to Generic Close Range (in mm).
- 3. Click OK.

Configure the parameters of incoming 3D Images

- 1. Menu: Config > Modify. A dialog box pops up.
- 2. In the Incoming images tab, set:
  - Alignment of new images: Do not Center
  - Max edge length: Automatic
- 3. Click Apply.
- 4. Click Close.

Save the configuration

- 1. Menu: Config > Save.
- 2. Click Yes. The saved configuration becomes the new default configuration.
2. Import and align 3D Images one at a time

This section’s goal is to reconstruct the whole part using scans taken from different orientations. Scans will be imported one at a time, converted to 3D Image format, and then aligned to the other 3D Images. A good analogy is that of fitting pieces to a puzzle.

* Note that while it is possible to edit 3D Image points in IMAlign, it is recommended to do it in the downstream IMEdit module or IMInspect module.
2.1 Import and lock the first 3D Image

2.1.1 Import the 3D Image

2. In the Import from area, select Standalone file or directory.
3. Open the Planar Grids/Meshes branch.
4. Click Neutral/InnovMetric (PIF).
5. Click Browse.
7. Select IMBase_1.pf.
8. Click Open.

After the import scan operation, the 3D scene shows a corresponding 3D Image. The object tree is displayed to the left. The scan has been converted to an IMAlign 3D Image, complete with icon and image index.

2.1.2 Lock the 3D Image

1. Select the 3D Image in the object tree.
2.2 Import the next 3D Image

3. Select IMBase_2.pf.
4. Click Open.

When you import a 3D Image, it is selected in the object tree. On importing a second or greater 3D Image, IMAlign automatically enters Split View alignment mode:

- The new 3D Image appears in the right viewport, the other non-selected 3D Images appear in the left viewport (see figure below).
- The Split View Mode dialog box appears (Dialog Zone). You may set Superimpose right images to see the contents of the right viewport superimposed on the contents of the left viewport. Note that you can exit Split View mode at any time by pressing the Split View Alignment button in the Processes toolbar.

The Split View Mode dialog box also features automatic alignment items. They are presented in Exercise #2 on page 38.
2.3 Align the new 3D Image

2.3.1 Pick one pair of matching points

1. In Split View Alignment mode, click the One Point Pair button in the dialog box.
2. In the left viewport, click on a 3D Image to define a first point.
3. In the right viewport, click on a 3D Image to define a matching point. You may need to use the Interrupt mode (see page 20) to rotate or zoom in on the 3D Image in the right viewport in order to pick a similar location.

After a 1 Point Pair alignment, IMAlign exits the Split View Alignment mode. The newly aligned 3D Image has been automatically aligned and locked (padlock on the 3D Image’s icon). Alignment statistics are displayed near the top of the 3D scene.

You may undo an alignment by choosing Edit > Undo Align (Point Pairs), by pressing the Undo button, or by pressing CTRL + Z on your keyboard.

If the 1 Point Pair alignment fails, you may unlock the newly added 3D Image (Image > Unlock), return to Split View Alignment mode, use the mouse to give a similar orientation to the 3D Images in the left and the right viewports, and perform another 1 Point Pair alignment.

2.4 Any more 3D Images...

If this is the last unaligned 3D Image, continue with “Optimize the global 3D Image alignment” on page 34. Otherwise, return to step 2.2 on page 32 and import and align the next 3D Image.
3. Optimize the global 3D Image alignment

The alignment technique used so far (1 Point Pair Alignment) provides a good approximation of the optimal alignment. The next step is to refine that alignment. Apply the iterative best-fit image alignment algorithm to the entire set of 3D Images to globally minimize the alignment errors.

3.1 Lock only one 3D Image

1. Menu: Select > Images > All.
3. Click on a 3D Image in the object tree.

3.2 Best-fit align all of the unlocked 3D Images (global alignment)

2. Click the Parameters tab.
3. Set:
   - No constraints
   - Max distance: default value
   - Subsampling: 1/1
   - Histogram range: Auto
   - Refresh mode: None
4. Click Start.

Note:

- The Convergence parameter at the bottom of the Parameters tab is the alignment algorithm's stopping criterion. It is also possible to enter a # of iterations after which the best-fit algorithm will stop. In both cases, you may manually stop the best-fit operation when the standard deviations do not decrease from one iteration to the next by pressing the Stop button.

- The Maximum distance parameter defines a maximum acceptable distance between a 3D Image point and an overlapping 3D Image. If the 3D Image point is farther than this maximum distance from another 3D Image, the point is ignored for alignment.
4. Analyze the quality of the alignment

IMAlign displays the alignment results for each 3D Image in the Statistics tab of the Best-fit Alignment & Comparison dialog box. IMAlign can also display histograms showing the distribution of points with regards to their distance from all overlapping 3D Images, which provides important information concerning the 3D Image alignment and quality.

**View statistics**

As soon as the best-fit alignment is started, the Statistics tab of the Alignment & Comparison dialog box opens. It displays convergence, mean, and standard deviation information for each 3D Image at each iteration of the alignment algorithm. 3D Images are identified by their index number. Note that the locked 3D Image is not included in the statistics. The objective here is to reach a near zero error and a standard deviation value neighboring the digitizer accuracy (1 sigma).

These statistics can help you decide to manually stop the alignment in progress, if the results remain similar for several iterations.

**View histograms**

IMAlign displays a histogram for each 3D Image, identified by its index number preceded by the letters Im (image) under the Histogram window docked under the Tree View window. Click the tab to view the histogram.

The histograms are updated throughout the alignment process, and a bell-shaped histogram centered about zero is a sign of a good result. A 3D Image that is not well aligned can be easily identified by looking at its histogram.
4.1 Analyze 3D Image deviations

It is possible to compare the 3D Images, show their alignment deviation, and identify 3D Images with problems, which may be caused by bad data, excessive noise, or other factors.

4.1.1 Select 3D Images

- To select all 3D Images: Select > Images > All.
- To select individual 3D Images, hold CTRL and click on individual 3D Images in the object tree.

4.1.2 Show the alignment deviations

2. Click the Comparison tab.
3. Set Deviation type to High to Low Image.
4. Click the Show Deviations button.

The errors are mapped to the part using a color scale displayed in the 3D scene.

4.1.3 Adjust the display

1. Set Maximum error to 0.05.
2. Click Update.

If any errors are off the scale (> Maximum error or < Minimum error and within the Maximum distance) they are represented using a dark grey color. Areas that have no overlap, and therefore no error values within the Maximum distance, are displayed using the default material color. Note that the types of color scales used for comparison operations are configurable.
5. **Save and exit**

Save the alignment results and any editing operations to an IMAlign Project.

1. Menu: File > Save Project As. A dialog box pops up.
2. Specify a project name and a workspace location.
3. Click **OK**.
5. Click **No** in the message window concerning overlap reduction.

The IMAlign module closes and the IMAlign Project has been saved to the specified workspace.
Exercise #2: Auto-align 3D Images

In Exercise #1, the 1 Point Pair Alignment technique was used to position the 3D Images (step 3). In some cases, it can be difficult to specify an appropriate point pair to match on both 3D Images because of a lack of recognizable features to associate. For those situations, PolyWorks includes a feature called Auto-align that does not require any point selection to perform the 3D Image alignment.

The following exercise lets you use the Auto-align tool with a different dataset; it does not go through the entire workflow shown on page 28.

1. Get ready

1. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.

2. In the PolyWorks/Workspace Manager, click on the IMAlign button in the Standard toolbar. The IMAlign module starts.

2. Import and automatically align 3D Images one at a time

Just like you did in Exercise #1, you will import 3D Images one at the time and align them. This time, however, you will use the Auto-align tool instead of the 1 Point Pair Alignment technique. The alignment result is similar, but it is generally accomplished faster since you do not have to find points to associate on each 3D Image. Remember that the Auto-align function is generally used when finding exact corresponding points on each 3D Image is not obvious.

2.1 Import and lock the first 3D Image

2.1.1 Import the 3D Image

2. In the Import from area, set Standalone file or directory.
3. Open the Planar Grids\Meshes branch.
4. Select the Neutral/InnovMetric (PIF) format.
5. Click Browse.

The 3D Image is now loaded in IMAlign (and the scan is loaded in the workspace).

2.1.2 Lock the 3D Image

1. Select Sheetmetal_001.pf in the object tree.

It is useful to set Config > Browsers to a working directory pointing at the location of your 3D Image directory. This will prevent having to specify the full path for each 3D Image to import.
2.2 Import and align the next 3D Image

2.2.1 Import and align the 3D Image

2. In the browser, select Sheetmetal_002.pf.

At this point, you automatically enter the Split View Alignment mode and a dialog box appears in the Dialog Zone (see figure below). Note that you can choose to show or not the 3D Image to align in the left viewport.

3. Set Superimpose right images in the Split View Mode dialog box to show that the alignment has been successfully performed.
4. Click Start in the Automatic alignment area of the Split View Mode dialog box to align the imported 3D Image.
5. Press the Split View Alignment button to exit the Split View Alignment mode.

Troubleshooting

If the 3D Image does not automatically align correctly to the already aligned 3D Images, click the One Point Pair button in the Split View Mode dialog box and perform a 1 Point Pair Alignment operation (see page 33) to obtain the appropriate result.

2.2.2 Lock the aligned 3D Image

1. Select the newly aligned 3D Image in the object tree.
B. Align the scans

Acquiring Data

2.3 Import and align remaining 3D Images

- Repeat step 2.2 for the remaining 3D Images (Sheetmetal_003.pf to Sheetmetal_006.pf).

The results

The aligned 3D Images are shown in the figure to the right.

Remaining steps

Now that all six 3D Images are positioned correctly, you would normally continue with the remaining steps that make up the typical workflow (optimize the 3D Image alignment and analyze it) — these steps are not presented here.

2. Click No in the message window concerning overlap reduction.
3. Click Yes in the message window if you wish to save the alignment project to the active workspace using the default name.
4. In the Workspace Manager: File > Close.

Note that additional information related to the completed exercises in this section is provided on page 105.
## Objective

Reverse engineering is a process that involves converting the aligned scans of a physical part, which may require editing, into a high-quality, highly accurate surface represented by polygons. If desired, NURBS surfaces may be fitted to the polygonal model for use in downstream applications, such as CAD software. The reverse-engineering process consists of three steps.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Illustration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A. Generate a polygonal model</strong></td>
<td><img src="image" alt="11 scans aligned" /> points in scans merged to form a polygonal model (holes made in mesh for exercise purposes)</td>
</tr>
<tr>
<td>Use <strong>IMMerge</strong> to create a polygonal model from the contents of an IMAlign Project. IMMerge offers smoothing that removes digitizer noise and intelligent reduction that reduces the number of triangles in planar regions while respecting object curvature.</td>
<td><img src="image" alt="improved polygonal model" /></td>
</tr>
<tr>
<td><strong>B. Improve the model</strong></td>
<td><img src="image" alt="improved polygonal model" /></td>
</tr>
<tr>
<td>It is normal that a model made from digitized datasets has some imperfections. Use <strong>IMEdit</strong> to improve the model: fill holes, extract sharp edges, optimize triangles, and perform local reductions.</td>
<td><img src="image" alt="11 scans aligned" /></td>
</tr>
<tr>
<td><strong>C. Create NURBS surfaces</strong></td>
<td><img src="image" alt="fitted NURBS surfaces" /></td>
</tr>
<tr>
<td>Use <strong>IMEdit</strong> to create a network of curves that will be used to fit NURBS surfaces to the polygonal model's surface. T-junctions and 3- and 4- sided patches are supported. Note that a powerful auto-nurbing function is also available, and that it can incorporate feature curves.</td>
<td></td>
</tr>
</tbody>
</table>
Data files

If you have copied the data files to your hard disk as explained on page 8, go to the next step. If you have not copied the files, please go to page 8 and follow the procedure. The directory that contains the data files should be named *PolyWorks V10 Beginner’s Guide Data*.

Get ready

1. If necessary, start the Workspace Manager by double-clicking on the PolyWorks shortcut on your Windows desktop.
2. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
3. Workspace Manager main menu: File > Open.
4. Select *PolyWorks_processes.pwk.pwzip*.
5. Specify a directory in the file browser and click OK; the Workspace Manager unzips the workspace in the directory and makes it the active workspace.
A. Generate a polygonal model

Use PolyWorks’ IMMerge module to create a highly accurate polygonal model from an IMAlign Project (contains scans aligned using the IMAlign module). The polygonal mesh is adapted to the object's curvature, and it is possible to control the triangle size, smooth the input data by removing digitizer noise, and significantly reduce the model size while respecting the object's shape. PolyWorks has demonstrated its capability for creating class A polygonal models for stringent polygonal manufacturing applications such as 3-axis & 5-axis milling, aerodynamic simulation, and digital review.

IMMerge basics

The IMMerge module is composed of a main parameter window, a 3D scene, and a text output area. The 3D scene shows the evolution of the meshing process using colors, and the text output area gives precise information as to the processing currently being performed. The 3D scene can be transformed using standard, mouse-based operations. If the meshing operation does not complete successfully the first time, the text output area provides useful diagnostic information.
Exercise #1: Generate a polygonal model

In this exercise you will generate a polygonal model using an IMAlign Project provided for you.

1. Start IMMerge

1. Select IMBlock_Aligned in the active workspace.
2. In the Wizard window of the Workspace Manager, click “Create a polygonal model”.

When the IMMerge window pops up, items already have values based on the selected IMAlign Project. The values can be changed if desired.

2. Set parameters

1. Set Smoothing level to Medium.
2. Make sure that Open in IMEdit after a successful merge is not set.
3. Click Advanced.
4. Check:
   • Show text output
   • Show 3D progress

3. Start the merging process

• Click Start.

The 3D scene will show the progress of the operation using colored areas: red – not yet processed, yellow – being processed, and green – processed.

When the creation of the polygonal model is complete, the last message In the text output area should read “IMMerge has ended successfully”. A polygonal model has been created under the Polygonal Models branch in the active workspace.

4. Exit IMMerge

• Click Close.

After the merging operation, the IMMerge module closes and the polygonal model is saved to the Polygonal Models branch of the active workspace.
**The results**

IMMerge has produced a mesh similar to the one in the snapshot below. The scans aligned in the IMAAlign Project have been merged to provide a high-quality polygonal model composed of a mesh that has been smoothed and intelligently reduced. This polygonal model can now be loaded into the IMEdit module to be improved.

![Polygonal model image]

**Additional information**

When the polygonal model is created, it appears in the active workspace under the Polygonal Models branch. The IMMerge parameters used to create the polygonal model are automatically added to the notes for this object. To see the parameters, select the polygonal model and read under Notes in the WM Wizard window.

**Performance**: IMMerge uses the available processors on your workstation for optimum performance. Even larger gains in performance can be achieved through IMMerge’s *cluster mode*. You install the IMMerge Agent, that comes with PolyWorks, on those workstations that you want to have participate in the merging task, including your workstation, if desired. You then configure the cluster mode by entering the workstation names. On launching the merge, the work to do is distributed to those workstations, and the results returned and combined at your host workstation. For complete information, see the IMMerge Reference Guide and the PolyWorks Reference Guide, available from the Workspace Manager’s Help menu.
B. Improve the polygonal model

The IMEdit module is PolyWork’s toolbox for preparing your polygonal model for your applications. You use composite Bézier curves and surfaces to enhance the model, Point and Plane primitives for a number of functions, and cross-sections to export the object’s shape. Curve networks can be created, and NURBS surfaces fitted to them and then exported to IGES.

In IMEdit, you will import a polygonal model, edit it, extract its shape using cross-sections, and generate NURBS surfaces based on the improved polygonal model. Once the editing is completed, the improved polygonal model may be exported to a number of standard formats. Finally, save your work to an IMEdit Project.

IMEdit basics

This section presents module-specific basics. The exercises begin on page 48.

The basic interface layout

The default IMEdit interface layout features three main windows: Tree View, Dialog Zone, and 3D Scene. The two toolbars that will be used often in the exercises to follow are indicated below.
Selecting objects

IMEdit functions like all other modules when selecting objects (explained on page 21). Interactive picking of objects in the 3D scene is launched by pressing the Pick Objects button. Specify the objects to select in the Picking Context dialog box that is displayed in the Dialog Zone.

Selecting object elements interactively

The interactive Selection mode, launched by pressing the Select Elements button, offers (a) region-based element selection, and (b) individual element selection.

(a) Region-based selection

When in Selection mode, the dialog box to the right appears (Dialog Zone).

- The top area specifies the elements to select.
- The two items at the bottom let you specify the elements to select when performing surface-based selections (Triangles or Vertices) and volume-based selections (Triangles or Vertices).

(b) Individual or menu-based triangle/vertex selection

In Selection mode:

- **Left**-clicking on a polygonal model selects vertices and **right**-clicking selects triangles.

The selection operates on either the triangle/vertex under the cursor. If the **SHIFT** key is not held down, an individual triangle or vertex is selected. If the **SHIFT** key is held down, a shortcut menu pops up offering several triangle/vertex selection operations.

The selection operation result depends on how the Selection mode is configured (see page 22).
**Exercise #1: A typical editing project**

**Objective**

Depending on the quality of your original scans, the polygonal model obtained from the merging process may need editing before it can be used by other downstream applications, such as direct manufacturing from the polygonal model or CFD analysis.

In this exercise, you will learn how to edit and clean up a polygonal model. The different tools are presented in the order in which we believe they are the most efficient (a brief description of other major IMEdit tools is provided on page 107). The basic editing workflow is presented below.

**Typical workflow**

```
Import
the polygonal model

Edit
the model

Optimize
the mesh

Extract
the model’s shape
```
B. Improve the polygonal model

1. Get ready

Start IMEdit

1. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
2. Select IMBlock_raw_model.pqk under the Polygonal Models branch of the active workspace.
3. In the Wizard window of the Workspace Manager, click “Improve the polygonal model and create NURBS surfaces”.

The IMEdit module opens with the polygonal model loaded. See under the Models branch of the IMEdit object tree.

Configure the browsers

Specify a path for importing/exporting standalone files/directories (not contained within a PolyWorks workspace). Part of standard practise but not used in this guide.

1. Menu: Config > Browsers.
2. Set Startup directory to Working Directory.
3. Click Browse.
4. Specify a path.
5. Click OK.

Turn the instructions Wizard off

1. Menu: Window.
2. Unset Interactive Mode Wizard.

Note that we strongly recommend turning the Wizard on for the first few weeks of using IMEdit.

2. Import the polygonal model

By starting IMEdit from the Workspace Manager with the file IMBlock_raw_model.pqk selected in the active workspace, as done above, the polygonal model is automatically imported in IMEdit.

If you need to import a polygonal model from the IMEdit module, choose File > Import Polygonal Model, and select a file from a workspace or from disk using the PolyWorks browser.
3. Edit the model

The editing to do in the following exercises includes filling holes automatically and manually, smoothing the surface, and reconstructing sharp edges.

3.1 Fill holes

This exercise shows two ways to fill holes:

- using automatic hole filling based on hole size
- using composite Bézier surfaces

3.1.1 Fill holes automatically

For automatic hole/gap filling, IMEdit uses a bridging distance to connect boundary perimeter points and create triangles. If the holes to fill are small, the new triangles may be flat. If the holes to fill are not small, you can specify the subdivision of the new triangles (curvature-based filling).

1. In the Polygonal Edition toolbar, click the Advanced Triangle Creation and Editing button.
2. Click the Automatic Hole Filling button. A dialog box pops up.
3. In the Fill in holes and gaps area, set Max distance to 5.0.
4. In the Hole-filling method area, set Avg. edge length to Automatic.
5. Set Confirm hole filling (navigate to and confirm each filled area).
6. Click Apply.
7. Click Yes in the message window (to process the whole model).
8. The Confirm Hole Filling dialog box appears (Dialog Zone). Press the Next and Previous buttons to navigate to and see each proposed filling zone. Use the Interrupt mode (press SPA-CEBAR) to position the model so that you can see the blue boundary highlighting the newly created triangles; the current zone is enclosed in a red box. Press the Delete button to delete a specific zone if not satisfactory.

9. Confirm all the hole filling by clicking Done.

10. Click Close.

3.1.2 Fill holes using a surface

Not all holes are properly filled by the automatic hole filling. Filling holes using a surface, while somewhat longer, proves to be more flexible and the power of PolyWorks lies in having the choice to use either method.

The figures below show the hole in the back side slot of the block. For this size and shape of hole, a typical approach is to anchor a composite Bézier surface to cover this hole. There are three steps:

- Anchor a M rows by N columns surface that respects the contour of the underlying mesh and not the shape of the hole – see the figures below.
- Fit the surface to the polygonal model.
- Triangulate the surface, thereby filling the hole.

![Best practice for Bézier surface creation](image)

**well-defined surface:**
- the surface respects the curvature of the mesh surrounding the hole
- rows delimit curvature zones at the top and the bottom of the slot wall

**poorly-defined surface:**
- the surface is oriented with respect to the hole shape
- rows or columns do not delimit the curvature of the underlying mesh features
Anchor the Surface

1. Orient the model and zoom in on the hole as show in the figure to the right and below.
2. In the Main Objects toolbar, click the **Surface Creation** button.
3. Click the **Create Surface by Anchoring a Rectangular Set of Rows and Columns** button. A dialog box appears (Dialog Zone).
4. Click **Advanced**.
5. Set **Max snap distance** to 5.

Below you will click points on the model to define a composite Bézier surface. See the figure to the right for an indication of where to click. Follow the procedure that continues below. You may need to use the Interrupt mode (explained on page 20).

6. Click the nine points in the first column.
7. Right-click a first time to end the first column. IMEdit now knows that each column will have nine clicks.
8. Click the nine points for each subsequent column.
9. Right-click after anchoring the last point of the last column. The surface is now defined.
10. Right-click to exit the mode.

A new surface is created, fitted to the model, and added to the Surfaces branch of the object tree.

Display the Surface using the Outline display mode

1. Select *surface 1* in the object tree.
2. Right-click and choose *View > Static > Outline*.

Modify the surface - add or remove rows

The previously fitted surface can be modified by adding or removing rows/columns.

1. In the Main Objects toolbar, click the **Surface Editing** button.
2. Click the **Delete Rows in Surface** button.
3. Place the pointer within the surface. IMEdit highlights the nearest row.
4. Click to delete the row indicated in the figure to the right.
5. Right-click to exit the mode.
6. In the Main Objects toolbar, click the **Surface Edition** button.
7. Click the **Add Rows to Surface** button.
8. Add a row to replace the one just deleted.
9. Right-click to exit the mode.
The surface seems similar to the one you already had prior to removing a row. However, it is necessary to re-fit the modified surface to ensure that each control point lies on the model.

**Fit the edited surface to the model**

1. Select the surface in the object tree.
2. In the Main Objects toolbar, click the *Surface Editing* button.
3. Click the *Fit Surfaces onto Models* button. A dialog box pops up.
4. Check *Show fitting error*.
5. Click *Apply*. Each vertex shows a deviation to the surface associated with the displayed color scale.
6. Unset *Show fitting error*. The color map will disappear.
7. Click *Close*.

**Triangulate the surface**

1. In the Main Objects toolbar, click the *Surface Editing* button.
2. Click the *Triangulate Hole using Surface* button. A dialog box pops up.
3. Set *Vertex sampling step* to 0.25.
4. Click *Apply*.
5. Middle-click over the surface in the object tree to hide it.

The vertex sampling step value must be well chosen for a good surface triangulation. You may press CTRL+Z to undo the triangulation and try other values: 2 – produces new triangles too large to properly fit areas of high curvature, 0.5 – much better, 0.25 – gives excellent results in areas of high curvature but a large number of small triangles (problem resolved by reducing the mesh in planar areas in “Optimize the polygonal mesh” on page 56).

**The result**

The result is a complex hole that is well filled. The newly triangulated surface blends in perfectly with the surrounding model.
3.2 Smooth vertices

Smoothing is performed on triangle vertices. It can be done globally, on selected regions, or manually using a brush. The model surface shown below needs to be smoothed.

3.2.1 Smooth interactively

1. Orient the model as shown above and zoom in on the indicated side.
2. In the Polygonal Edition toolbar, click the Vertex Editing button.
3. Click the Smooth Vertices via a Selection or Interactively button. A dialog box pops up.
4. Set Radius to 0.75.
5. Click Interactive.
6. (Optional) Set in the Interactive Selection dialog box:
   - Brush shape: Rectangle
   - Brush width: 100
   - Brush height: 100
7. Place the pointer over the surface to be smoothed.
8. Click once to smooth the area beneath the brush. Try it again elsewhere to see the results.
9. Click Close.

3.2.2 Smooth a selection

1. Zoom in on the same part side so that you can see the complete side in the 3D scene.
2. With the focus in the 3D scene, press SPACEBAR to enter Selection mode.
3. Make sure Model triangles/vertices is checked in the Selection Context dialog box.
4. Select the surface shown in the figure to the right (CTRL + middle-click to define the contour points and right-click to close the contour). It is important to not select any fillet area, as a high smoothing radius can decrease fillet quality.
5. Press SPACEBAR to exit Selection mode.
6. In the Polygonal Edition toolbar, click the Vertex Editing button.
7. Click the Smooth Vertices via a Selection or Interactively button. A dialog box pops up.
8. Set Radius to 0.75.
9. Click Apply.
10. Click Close.

In the case where no element selection (vertices) had been made prior to pressing the Apply button, IMEdit would have asked you if you wanted to apply the smoothing to all model vertices. This is how you can apply the smoothing function to the entire model in one simple operation.
3.3 Extract sharp edges

A big part of model editing is feature curve extraction and sharp edge reconstruction. Here you will use the feature tracking tool to extract the theoretical sharp edge of the hole shown in the figure to the right. The feature tracking function is a very powerful tool that allows you to extract tangent fillet curves, sharp edges, and feature center curves automatically.

3.3.1 Sharp edge extraction

1. Zoom in on a hole (see the figure to the right).
2. In the Main Objects toolbar, click the Curve Creation button.
3. Click the Track Feature to Create Curves button. A dialog box appears (Dialog Zone).
4. Set:
   - Method: 1 point
   - Sharp edge curve
   - Tangent curves: None
5. Place the pointer on the center of the fillet of a hole, then click and drag a cylinder the approximate size of the fillet (see first figure).
6. Right-click to exit the picking mode.

You will obtain a closed curve floating above the model, as shown in the second figure.

3.3.2 Sharp edge insertion

Insertion is where triangles are added or modified to include a specific curve in a polygonal model.

1. Select the curve just extracted in the object tree.
2. In the Main Objects toolbar, click the Curve Editing button.
3. Click the Insert Curve button. A dialog box pops up.
4. Set Insertion method to Type Specific (for edge curves, triangles are inserted on both sides of the curve).
5. Set Sampling step to Variable.
6. Click Insert.
7. Click Yes.
8. Click Close.

You now have a sharp edge inserted into the polygonal model. This operation can be performed for concavities as well as convexities. You can try to reconstruct other sharp edges on your part.
4. Optimize the polygonal mesh

This part of the exercise includes two steps: optimizing the mesh and then reducing the mesh.

4.1 Optimize the mesh

A mesh is optimized when triangle edges are parallel to the flow of a contour. An optimized mesh bends to conform to the flow of the shape, providing a smoother surface. IMEdit uses angle criteria to determine if there should be an edge swap for each triangle. Mesh optimization may be applied to a selection, or to the entire model.

In the following step of the exercise, the entire model will be optimized. In zooming on the top surface of the through slot area, in flat display mode, the optimization effects are clear.

![through slot area before optimization](image1)

![through slot area after optimization](image2)

has a slightly smoother surface

After mesh optimization, the triangulated mesh is more consistent, and the surface curvature is better described. Note that mesh optimization works best when the polygonal mesh is relatively smooth.

1. In the Polygonal Edition toolbar, click the Advanced Triangle Creation and Editing button.
2. Click the Optimize Mesh button.
3. Click Apply. A message window pops up asking if you want to apply the optimization to the entire model.
4. Click Yes (to apply the optimization to the entire model).
5. Once the operation is complete, click Close.
4.2 Reduce the mesh

Reducing (compressing) the mesh is an operation where triangles are removed from the mesh without changing the accuracy of the overall model – triangles are removed over flat areas and small triangles are kept in the highly curved or highly detailed areas. You can reduce part or all of the polygonal mesh. Reduction is normally done once the editing work is finished.

4.2.1 Select a group of triangles

IMEdit creates a group of triangles when holes are filled. The group created by the Bézier surface triangulation will be used to demonstrate mesh reduction.

1. In the object tree, click on the “+” that precedes the polygonal model.
2. Under the Groups branch, select the last group with the name that starts with cs_fill.
3. Right-click and choose Select Elements > Group Triangles.
4. Select > Grow 1 (increases the selected area by 1 layer of triangles).

4.2.2 Reduce the triangles

1. In the Polygonal Edition toolbar, click the Advanced Triangle Creation and Editing button.
2. Click the Reduce Mesh with IMCompress button. A dialog box pops up.
3. Set Tolerance to .003 (same value as the reduction tolerance in IMMerge).
4. Click Apply.
5. Once the operation is complete, click Close.

For more information on IMCompress, see “IMEdit – IMCompress parameters” on page 111.

The result

The reduction results in a reduced vertex density and larger triangles in the flat areas, while preserving curvature. IMEdit preserves the boundary of selected area during the reduction process.

Note that the opposite process is also offered: Model > Triangles (Advanced) > Subdivide.
5. Extract the shape of the model

In some applications, the polygonal model can provide important information on the shape of an object. Cross-sections are commonly used to get that information on several locations of the model. IMEdit offers simple tools to generate cross-sections and export them to specific file formats.

5.1 Generate cross-sections along the X axis

1. Menu: Edit > Cross-Section > Create Numerically. A dialog box pops up.
2. Set:
   - **Type**: X axis
   - **Step**: 10.0
   - **X seed**: 5.0
3. Click **Apply**.
4. Click **Yes** in the message window.
5. When the operation is complete, click **Close**.

From those commands, 11 cross-sections are created along the X axis from x = 5, 15, 25, 35, 45, 55, 65, 75, 85, 95, 105 as shown below. You can hide the model to improve cross-section viewing.

5.2 Export the cross-sections to IGES

1. In the object tree, select all of the cross-sections.
2. Menu: File > Export Objects > Cross-Sections to IGES. A file browser pops up.
3. Specify a file name and location.
4. Specify **mm** (millimeters) in the **IGES unit** combo box.
5. Click **Save**.
6. Export the edited polygonal model

You may export the edited polygonal model to disk as a standalone file or to a workspace.

6.1 Export the polygonal model to disk as a standalone file

2. In the Export to area, set Standalone file.
3. Specify a file location and name.
4. In the Save as type combo box, specify STL Files.
5. Click Save.

6.2 Export the polygonal model to a workspace

2. In the Export to area, set Workspace.
3. Specify an object name.
4. Use the Workspace location combo box to specify a destination workspace. Use the Add Workspace button to add workspaces to the combo box. Then, select the desired workspace.
5. Click Export.

7. Save the IMEdit editing project

The Workspace Manager automatically takes a snapshot of the IMEdit Project on closing as part of a project's documentation. When you select the IMEdit Project in the Workspaces window of the Workspace Manager, you can see the snapshot in the Wizard window under Last Saved View.

2. Specify a project name and a workspace location.
3. Click OK.
C. Create NURBS surfaces

Non-Uniform Rational B-Spline (NURBS) are curves or surfaces that are used in computer graphics to represent complex objects. In PolyWorks, NURBS surfaces are built on polygonal models by first fitting a curve network on its triangles, and then fitting NURBS surfaces on the polygonal model based on the curve network. PolyWorks supports T-junctions and triangular patches, can build surfaces over holes, and provides tolerance-based G0-continuous (position), G1-continuous (tangent), and G2-continuous (curvature) NURBS surfaces.

The polygonal model is the starting point for the generation of good-quality NURBS surfaces. While NURBS surfaces can be fit over holes or on rough surfaces, we recommend cleaning up the polygonal model, especially on the boundaries and those areas where you will need to build curves. We also recommend limiting the compression of the model, as more triangles results in a better surface fit.

Manual surfacing

The first step in manual surfacing, and the one that determines the quality of the NURBS surfaces, is building the curve network. A curve network is built by extracting curves that represent the object’s boundaries and features and then adding curves to complete the curve set. All curves must be magnetized to all intersected curves. Most curve creation operations offer automatic magnetization to intersected curves. Furthermore, patches may have four boundaries (rectangular) or three boundaries (triangular), and T-junctions are supported. If five- or six-sided patches are detected during the create curve network operation, a wizard pops up that proposes solutions for subdividing the patches. Any invalid patches are excluded from the curve network. Exercise #1, on page 61, guides you through this process.

Hint: when picking curves you may need to use the Interrupt mode (see page 20) to temporarily leave the picking mode, move the 3D scene, and return to the picking mode.

Automatic surfacing

InnovMetric Software has developed a powerful tool that can automatically create a curve network, and use it to fit NURBS surfaces on a polygonal model. You may extract boundary curves and the automatic tool will use these curves in its final solution. A guiding principal behind this tool is to only provide high-quality NURBS surfaces where possible; as a result, there may be parts of a model that are not covered by the curve network. Exercise #2, on page 72, guides you through this process.

The part

The part that was digitized for this exercise is shown in the figure to the right; it is part of the dash of a car. The scans were aligned in the IMAlign module, and a polygonal mesh was created using the IMMerge module.
Exercise #1: Create NURBS surfaces - manual method

In this exercise, you will create NURBS surfaces using the manual method following this workflow:

1. **Extract** feature curves
2. **Complete** the curve set in order to create rectangular or triangular patches
3. **Create** a curve network
4. **Fit** NURBS surfaces on model using the curve network
5. **Export** NURBS surfaces to IGES
1. **Get ready**

1. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
2. Select the polygonal model *Model_for_NURBS.pqk* in the active workspace.
3. In the Wizard window, click “Improve the polygonal model and create NURBS surfaces”.

2. **Extract feature curves**

The objective here is to create curves that define the model’s geometry, such as fillets and boundaries.

### 2.1 Extract boundary curves

#### 2.1.1 Extract a closed boundary curve

1. In the Main Objects toolbar, click the *Curve Creation* button.
2. Click the *Anchor Closed Boundary Curve* button.
3. Place the pointer near the back boundary — when it is close enough it will be tracked as you displace the pointer along the boundary.
4. Click somewhere (see (a) in the figure below) on the back boundary. A dialog box appears (Dialog Zone).
5. Click *Done* to accept the default filter radius.
6. Right-click to exit the mode.

A curve (*curve 1*) has been created under the Curves branch in the object tree.

![Diagram](image-url)
2.1.2 Extract two open boundary curves

1. In the Main Objects toolbar, click the *Curve Creation* button.
2. Click the *Anchor Open Boundary Curve* button.
3. Click on each corner tip (see “x”s in the figure below) to delimit the boundary, and once more (see “a” below) to indicate the side of the boundary. A dialog box appears (Dialog Zone).
4. Click *Done*. An open curve is created (*curve 2*).
5. Click on the same two corners and once more (b) to indicate the longer side of the boundary. A dialog box appears (Dialog Zone).
6. Click *Done*. An open curve is created (*curve 3*).
7. Right-click to exit the mode.

---

2.2 Track feature curves

2.2.1 Track a feature curve

1. In the Main Objects toolbar, click the *Curve Creation* button.
2. Click the *Track Feature to Create Curves* button. A dialog box appears (Dialog Zone).
3. Unset *Sharp edge curve*.
4. Click on the feature center (see (1) in the figure below) and drag to encompass the feature.
5. On releasing the mouse button, the feature is tracked and two tangent curves are extracted (*edge 1 tg 1* and *edge 1 tg 2*).
6. Right-click to exit the mode.
2.2.2 Connect the tangent curve endpoints to other curves

1. In the Main Objects toolbar, click the Curve Editing button.
2. Click the Extend Open Curve button.
3. Move the pointer near the endpoint of a tangent curve, which is then highlighted, and click to select it.
4. Move the pointer to intersect the boundary curve while keeping the tangent direction. When the pointer is over the boundary curve, click. The point of intersection should be displayed in purple to show magnetization of the two curves. Right-click to launch the extension.
5. Repeat steps 2 and 3 for each tangent curve endpoint.
6. Right-click to exit the mode.

2.3 Anchor curves manually

Anchoring curves manually is done by picking points on the model surface to describe a feature. A few points can describe a planar feature, while more points are required as the degree of curvature increases.

When in anchoring mode:

- to anchor a point on the model, click over the model
- to anchor a point on a curve, hold down the SHIFT key and IMEdit tracks the pointer on the nearest curve, then click to anchor a point on the curve
- to erase the last point, middle-click

In this step, the display will be set to show the curvature in the model. Curves will be anchored following the curvature.

- Menu: View > Model Default Static > Curvature.
2.3.1 Anchor a closed curve

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Closed Curve button.
3. Click along the inside edge of the turquoise shading starting at (a) going completely around to (b) and right-click; the curve is automatically closed.
4. Right-click to exit the mode.

2.3.2 Anchor open curves

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Open Curve button.
3. Click to anchor points along the curvature (the outside edge of the turquoise shading) as in (1) in the figure below.
4. Right-click after anchoring the last point.
5. Repeat steps 2 and 3 for the similar feature on the right side of the part, as in (2) in the figure below.
6. Right-click to exit the mode.
3. Complete the curve set

The goal here is to connect the feature curves. You will create curves quickly using cross-sections, or pick curves manually. Both methods offer automatic magnetization to intersected curves. Where two curves intersect, a new control point is created on each curve and they are magnetized (displayed in purple). The final set of curves will be used to create a curve network that supports only triangular and rectangular patches.

3.1 Create curves using cross-sections

3.1.1 Create curves by sectioning the entire model

The snapshot below indicates where to create curves that intersect the feature curves in the instructions below. Note that they will automatically be magnetized to intersected curves.

In this picking mode, you may pick outside of the object to each side (see the position of the letters in the snapshot below). IMEdit creates cross-sections that are converted to curves.

Prepare the model

1. Menu: View > Pose > View +z.

Create curves by picking two points

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Curve by Cross-Section (Pick 2) button.
3. Click twice away from the model (the two letter “a”s in the figure above). Two curves are created in the object tree.
4. Repeat this for the other pair of letters. Two curves are created in the object tree.
5. Right-click to exit the mode.
C. Create NURBS surfaces

3.1.2 Create curves by sectioning part of the model

The snapshot below indicates where to create more curves that intersect the feature curves.

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Curve by Cross-Section (Pick 2) button.
3. Click twice away from the model (the two letter “c”s above). A new curve is created.
4. Repeat step 3 for each subsequent pair of letters.
5. Right-click to exit the mode.

3.2 Add additional curves manually

A few more curves need to be added manually.

3.2.1 Anchor open curves

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Open Curve button.
3. SHIFT-click on the circled magnetized control point (see bottom of (1) in the figure below), then anchor points toward the boundary curve at the back, and SHIFT-click to anchor the last point on the boundary curve.
4. Right-click to end the curve.
5. Repeat steps 3 and 4 for the similar situation shown in (2) in the figure below.
6. Right-click to exit the mode.
3.2.2 Create curves from cross-sections

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Curve by Cross-Section (Pick 2) button.
3. Click twice away from the model (see (1) in the figure below). Make sure that the cross-section lies on or before the endpoint circled in red. A new curve is created.
4. Repeat step 3 for the similar situation shown in (2) in the figure below.
5. Right-click to exit the mode.
### 3.2.3 Anchor more open curves

1. In the Main Objects toolbar, click the *Curve Creation* button.
2. Click the *Anchor Open Curve* button.
3. SHIFT-click on the closed boundary curve near “a” in (1) in the figure below, and anchor points ending at “b”. End the curve. A magnetized control point is created at “b”.
4. SHIFT-click on the control point at “b” and create the curve bc.
5. SHIFT-click on the control point at “b” and create the curve bd.
6. Repeat steps 3 to 5 for the area in (2) in the figure below.
7. Right-click to exit the mode.

Make sure that where the curves intersect, they are magnetized (shown by purple control points).
4. Create the curve network

The basic conditions for creating a curve network have been met: the feature curves describe the object, the curve set is complete, the curves are magnetized at their intersections, and these intersections form 3- or 4-sided patches.

4.1 Create the curve network

1. Select the set of feature curves in the object tree.
2. In the Main Objects toolbar, click the Curve Network Creation button. 
3. Click the Create Curve Network from Curves button.

If IMEdit detects invalid 5-sided or 6-sided patches in the curve network, continue with the next procedure.

1. In the message window, click Yes. A dialog box pops up.
2. Check Allow triangular patch in solutions.
3. Click OK. A dialog box appears (Dialog Zone).
4. Click Previous and Next to navigate between 5-sided or 6-sided patches.
5. In the Patch subdivision area, click Previous solution and Next solution to view solutions. Click Confirm to choose the current solution.
6. When all patches have been corrected, click Done.

A curve network object is created in the Curve Networks branch of the object tree. IMEdit automatically hides the set of curves used to create the curve network object. Once created, a curve network object is totally independent of the set of curves used for its creation. For example, they could be deleted if they are not required for other purposes.

5. Fit NURBS surfaces on the model using the curve network

The only requirement for fitting NURBS surfaces on a polygonal model is a valid curve network.
C. Create NURBS surfaces

5.1 Fit NURBS surfaces over the entire curve network

1. Select the curve network object in the object tree.
2. In the Main Objects toolbar, click the Curve Network Editing button.
3. Click the Create NURBS from Curve Network button. A dialog box pops up.
4. Set # of control points on boundaries to 8.
5. Set Angular tolerance (in degrees) to 0.1.
6. Click Apply.
7. Once the operation is complete, click Close.

5.2 Evaluate the resulting NURBS surfaces

1. Select the network object under the Curve Networks branch in the object tree.
2. Right-click over the selected network and choose View > Static > Show Normal Deviations (in degrees). Look at the display.
3. Right-click over the selected network and choose View > Static > Show Fitting Errors.
4. When you are done, right-click over the selected curve network in the object tree and choose View > Static > No Color Mapping.

6. Export the fitted NURBS surfaces

1. Right-click over the selected network and choose Export > NURBS Surfaces to IGES. A file browser pops up.
2. Provide a file name.
3. Click Save.

7. Save the IMEdit editing project and exit

2. Specify a project name and a workspace location.
3. Click OK.
Exercise #2: Create NURBS surfaces - automatic method

In this exercise, you will extract three feature curves and the auto-nurbing tool will do the rest.

1. Get ready

1. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
2. Select the polygonal model Model_for_NURBS.pqk in the active workspace.
3. In the Wizard window, click “Improve the polygonal model and create NURBS surfaces”.

2. Extract feature curves

The objective is to create curves that define the model’s geometry, such as fillets and boundaries.

2.1 Extract boundary curves

2.1.1 Extract a closed boundary curve

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Closed Boundary Curve button.
3. Place the pointer near the back boundary — when it is close enough it will be tracked as you displace the pointer along the boundary.
4. Click somewhere (see (1) in the figure below) on the back boundary. A dialog box appears (Dialog Zone).
5. Click Done to accept the default filter radius.
6. Right-click to exit the mode.

Note that a curve (curve 1) has been created under the Curves branch in the object tree.
2.1.2 Extract two open boundary curves

1. In the Main Objects toolbar, click the Curve Creation button.
2. Click the Anchor Open Boundary Curve button.
3. Click precisely on each corner tip (x) to delimit the boundary, and once more (a) to indicate choosing the shorter side of the boundary. A dialog box appears (Dialog Zone).
4. Click Done. An open curve is created (curve 2).
5. Click on the same two corners and once more (b) to indicate choosing the longer side of the boundary. A dialog box appears (Dialog Zone).
6. Click Done. An open curve is created (curve 3).
7. Right-click to exit the mode.

3. Perform the auto-nurbing

You have extracted the model’s boundary curves and will use the auto-nurbing tool. Compare the curve networks/NURBS surfaces produced using the manual and automatic nurbing processes.

1. Select the three curves created above in the object tree.
2. In the Main Objects toolbar, click the Curve Network Creation button.
3. Click the Create Curve Network Automatically using Model button. A dialog box pops up.
4. Set Roughness of polygonal model to Low.
5. Click Apply.
6. Click Yes to use all of the model’s triangles.
7. When the operation is finished, click Close.
The results

The result is shown below. The auto-nurbing operation has quickly covered the majority of the surface with good-quality NURBS. There are three holes. You could easily add/magnetize curves manually using tools seen in the previous exercise to complete the curve network, fit NURBS surfaces to the model using the new curve network, and exporting the NURBS surfaces to IGES.

4. Save the IMEdit editing project and exit

2. Specify a project name and a workspace location.
3. Click OK.

Control returns to the Workspace Manager.
### Objective

The inspection process typically uses the aligned datasets as the Data object, which is compared to a NURBS-based Reference object. The inspection process consists of these two steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Illustration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A. Inspect the digitized part</strong></td>
<td></td>
</tr>
<tr>
<td>Use <strong>IMInspect</strong> to inspect the digitized parts within user-specified tolerances.</td>
<td></td>
</tr>
<tr>
<td>Inspection typically involves these steps:</td>
<td></td>
</tr>
<tr>
<td>• Align a Data object to a Reference object (best-fit or feature-based alignment).</td>
<td></td>
</tr>
<tr>
<td>• Measure by making global and local comparisons and by taking interactive measurements.</td>
<td></td>
</tr>
<tr>
<td>• Report the results.</td>
<td></td>
</tr>
<tr>
<td><strong>B. Share the results</strong></td>
<td></td>
</tr>
<tr>
<td>The inspection project can then be shared with associates using the free viewer <strong>IMView</strong>.</td>
<td></td>
</tr>
<tr>
<td>Others can quickly view inspection results, create new report items, and create new formatted reports that meet their needs.</td>
<td></td>
</tr>
<tr>
<td>IMView does not offer alignment or comparison operations.</td>
<td></td>
</tr>
<tr>
<td>IMView lets you view inspection results by category. Navigate through categories using arrows. IMView uses predetermined views for each category to show you only what you need to see. You may exit this navigation mode and view the object tree (not shown above).</td>
<td></td>
</tr>
</tbody>
</table>
Data Files

- If you have copied the data files to your hard disk, as explained on page 8, go to the next step. If you have not, please go to page 8 and follow the procedure. The directory that contains the data files should be named *PolyWorks V10 Beginner’s Guide Data*.

Get Ready

The inspection exercises use files and projects in the PolyWorks_processes.pwk workspace.

1. If necessary, start the Workspace Manager by double-clicking on the PolyWorks shortcut on your Windows desktop.
2. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
3. If you did the reverse-engineering exercises, select *PolyWorks_processes.pwk* in the Open recent workspaces area of the Open or Create Workspace dialog, and press the Open Selected button. The workspace is opened and is the active workspace.
4. If you did not do the reverse-engineering exercises, click Browse in the Open or Create Workspace dialog and specify *PolyWorks_processes.pwk.pwzip* in the browser window. Then, click Open, and then specify a directory for uncompressing the workspace – the Workspace Manager uncompresses the workspace and makes it the active workspace.
A. Inspect the digitized part

IMInspect is a powerful software solution that uses high-density point clouds to control the quality of castings/dies/molds and to approve manufacturing processes through prototype, first-article, manufactured, and assembled parts inspection. IMInspect offers a complete toolset for comparing forms and profiles (part-to-part and part-to-CAD), and includes the most complete GD&T (Geometric Dimensioning and Tolerancing) analysis capabilities on the market, as well as the widest array of soft-gauging tools. IMInspect also offers unprecedented automation capabilities with its macro recorder and user-friendly scripting language - execute an entire inspection sequence with complete reports in one click of the mouse.

IMInspect basics

This section presents module-specific basics. The exercises begin on page 79.

The basic interface layout

The default IMInspect interface layout features four windows: Tree Views, Dialog Zone, 3D scene, and Feature Controls. The two toolbars that will be used often in the exercises are indicated below.

![IMInspect interface layout](image-url)
Selecting objects

Many IMInspect operations may require that you pre-select one or more objects. To launch the picking mode, click on the Select Objects button in the Standard toolbar.

The Picking Context dialog box, that appears in the Dialog Zone, lets you set the type of objects to be selected.

Object Selection Wizard

If an object is not pre-selected, or incorrect objects are selected for a specific operation, the Object Selection wizard pops up. It explains the requirement that has not been met. Select the missing object(s) and press the Continue button. To enable/disable the Wizard, choose Window > Object Selection Wizard.

Selecting object elements interactively

The interactive Selection mode, launched by pressing the Select Elements button, offers (a) region-based element selection and (b) individual element selection.

(a) Selecting elements by region

IMInspect’s Selection Context dialog box, that appears in the Dialog Zone, offers standard items for contour-based selections. In the Elements to select area, you specify the type of elements to select.

Note that contour-based selections are performed using the middle mouse button, and are explained in detail on page 22.

(b) Selecting elements individually

In Selection mode, select elements by:

• Left-clicking over an object element to select it; for a polygonal Data object, you can click near a vertex and IMInspect finds the nearest 3D point.

• SHIFT+left-clicking over a polygonal or NURBS surface – a shortcut menu pops up offering object-based items.
Exercise #1: A typical inspection project

Objective

The exercises that follow will guide you through a typical inspection process. You will find step-by-step procedures for using the basic tools. For a brief description of other major tools, see page 115. At the end of the exercise, you will have realized a complete inspection project. The workflow is indicated below:

Inspection – A. Inspect the digitized part

<table>
<thead>
<tr>
<th>Define Reference</th>
<th>Acquire Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Import CAD</td>
<td>1. Import or scan Data</td>
</tr>
<tr>
<td>2. Create Features containing nominal Primitives</td>
<td></td>
</tr>
</tbody>
</table>

Align

1. Pre-align (Best-fit)

Acquire Data (continued)

2. Auto-extract Measured Primitives

Align (continued)

2. Feature-based alignment

Measure

Report
1. Get ready

Start IMInspect

1. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.

2. Click the IMInspect module icon in the PolyWorks/Workspace Manager Standard toolbar to open an IMInspect module.

Configure the browser

The path specified in the browser will be used for all import and export operations that make reference to standalone files or directories (not part of a workspace).

1. Menu: Config > Browsers. A dialog box pops up.
2. Set Startup directory to Working Directory.
3. Specify the working directory by clicking Browse and browsing to the directory on your hard disk containing the reference CAD file to import: PolyWorks V10 Beginner’s Guide Data\Reference Object.
4. Click OK.

Set the project units

1. Menu: Config > Units. A dialog box pops up.
2. Set Units to Millimeters.
3. Click OK.

Note: this sets the value for dialog box items to a suggested value for the units chosen. This does not change the size of any objects on the screen, or set the units of scanning. The units in which scans are made are set up in either the plug-in for the scanner or in the scanner's software.

Set the Wizards

1. Menu: Window.
2. Unset Interactive Mode Wizard.
   * When working with your own projects, turn this Wizard on for instructions.
4. Check Object Selection Wizard.

Note: we turn off the wizards for the exercises to make the instructions simpler in this book. When you work on your projects, the Wizards provide first-time users with valuable information.

Save the IMInspect configuration

1. Menu: Config > Save.
2. Click OK.

This configuration will now be the default configuration the next time you start IMInspect.
2. Define the Reference object

The Reference object typically refers to the perfect, theoretical CAD model that provides the exact mathematical model of the part. For this project, the CAD reference file is an IGES file containing surfaces represented using NURBS. This acronym stands for Non-Uniform Rational B-Splines. Starting from this point, the Reference object may also be called "NURBS model." It is in fact a synonym when the reference comes from a CAD software, like this one here.

2.1 Import the Reference object

2.1.1 Import and tessellate

On importing, IMInspect tessellates the contents of the CAD Reference file within a specified tolerance. As a result, surfaces are represented using triangles. The tessellation tolerance should be 10 times smaller than the smallest feature that you want to inspect.

3. Select IMBlock_CAD.igs.
4. Click Open. A dialog box pops up.
5. Set Suggested tessellation tolerance to 0.005.
6. Click OK.

Note that the imported CAD model does not appear in the active workspace as a separate object. This is because NURBS-based Reference objects are saved as part of the IMInspect Project, in an archive file.

2.1.2 Verify the NURBS model

IMInspect automatically corrects the orientation of NURBS surfaces on import. This may also be done manually at any time:

1. Select the Reference object in the object tree.

2.1.3 Assign Tolerances to the Reference object

1. Select the Reference object in the object tree.
3. Set:
   - Positive high: 1.0
   - Positive low: 0.5
   - Negative low: -0.5
   - Negative high: -1.0
4. Click OK.

### 2.2 Create Features on the Reference object

IMInspec has a picking tool for extracting Features on a Reference object. Features contain Primitives that are mathematical representations of the geometrical features.

#### 2.2.1 Create 3 planes

1. In the Main Objects toolbar, click the Feature Creation button.
2. Click the Create Plane Feature button. A dialog box appears (Dialog Zone).
3. Set Creation Method to Pick on NURBS.
4. Make sure Status is set to Nominal.
5. Click Pick.
6. Click three times on the Reference object (in order: 1 -> 2 -> 3) to extract 3 planes.
7. Right-click when finished.

#### 2.2.2 Create a vector

1. In the Main Objects toolbar, click the Feature Creation button.
2. Click the Create Vector Feature button. A dialog box appears (Dialog Zone).
3. Set Creation Method to Construct from Intersection and Sub-method to 2 Planes.
4. Select plane 1 and plane 2 in the object tree.
5. Click Create.

#### 2.2.3 Create a point

1. In the Main Objects toolbar, click the Feature Creation button.
2. Click the Create Point Feature button. A dialog box appears (Dialog Zone).
3. Set Creation Method to Construct from Intersection and Sub-method to 3 Planes.
4. Select plane 1, plane 2, and plane 3 in the object tree.
5. Click Create.
3. Acquire the Data object

The Data object is typically a point cloud captured by a 3D digitizer – it is a 3D representation of the manufactured part. For this exercise, the Data object is an IMAlign Project containing the aligned scans of the block.

1. Menu: File > Import Data > IMAlign Project. The PolyWorks browser pops up.
2. In the Import from area, specify Workspace.
3. Select IMBlock_Aligned and click Import. A dialog box pops up.
4. Click OK.

4. Align the Data object to the Reference object

IMInspect offers various alignment techniques to align the Data object in the Reference coordinate system. In this exercise, two techniques are used. An initial best-fit alignment is performed followed by a feature-based alignment.

4.1 Pre-align using a best-fit alignment

The best-fit alignment minimizes the Data-to-Reference deviation using all of the data points. It is useful to bring the Data and the Reference in the same coordinate system in order to identify common features that will be used to refine the alignment (Feature-based alignment).

1. In the Main Processes toolbar, click the Alignment Processes button.
2. Click the Best-fit Alignment button. A dialog box pops up.
3. Check Use automatic initial guess.
4. Unset Use constraints.
5. Check Use data segmentation.
6. Set Maximum distance to 4.0.
7. Check Use max angle and enter 45 in the adjacent text box.
8. Check Automatic convergence.
9. Click Start. When the operation is completed, click Close.
4.2 Auto-extract measured Primitives on the Data object

IMInspect offers a powerful tool for automatically extracting measured Primitives from nominal Primitives. This item allows you to quickly obtain measured Primitives necessary for alignment or measurement purposes.

4.2.1 Auto-extract the measured Primitives

1. Select the 5 Feature objects in the object tree.

4.3 Align using Features

The best-fit alignment discussed previously is a great tool for pre-alignment, but, most of the time, it is preferable to align the Data object to the Reference object using geometrical features.

In the following section, you will align the Data object using a feature-based alignment technique: 2 Planes, 2 Axes, 2 Center Points.

4.3.1 Perform a Feature-based alignment (2 Planes, 2 Axes, 2 Center Points)

1. In the Main Processes toolbar, click the Alignment Processes button.
2. Click the 2 Planes, 2 Axes, 2 Center Points Alignment button. A dialog box pops up.
3. You enter an interactive selection mode. Click in the 3D scene on, in order, the annotations of plane 1, vector 1, and point 1. The pairs of Primitives are automatically defined (see the figure below).
4. Click Align All.
5. Click Done. The feature-based alignment has been performed.

The three pairs of Primitives – source measured Primitives from the Data object and their corresponding destination nominal Primitives from the Reference object.
5. Measure

IMInspect offers several Data-to-Reference measurement techniques, including comparison and basic measurement tools. The comparison tools are generally used to measure the deviation of the general shape of the object. Two comparison tools will be used in this exercise: compare using all data points and compare using Cross-Sections. Then, you will learn how to take basic measurements.

5.1 Compare using all data points

This comparison tool computes the Data-to-Reference deviation on all or selected Data points.

5.1.1 View only the Data and Reference objects

1. Select the Data and Reference objects in the object tree.

5.1.2 Compare using all data points

1. In the Main Processes toolbar, click the Comparison Processes button.
2. Click the Compare Data to Reference for All Data Points button. A dialog box pops up.
3. Check Max angle.
4. Click Continue.
5. Menu: View > Pose > View z+.

A color scale is displayed to show the deviations of the Data object compared to the Reference object. Note that your color scale may differ slightly from the one in the guide.

5.1.3 Edit the color scale

1. In the Main Processes toolbar, click the Comparison Processes button.
2. Click the Comparison Error Display Options button. A dialog box pops up.
3. Set Conversion to colors to Use Object/NURBS Tolerances.
4. Set Scale type to pass/fail.
5. Click Apply.
6. Click Close.

The color scale now displays a pass/fail (green & red) scheme using the tolerances assigned to the Reference object. Color scales are customizable in PolyWorks.
5.1.4 View the comparison report

When using comparison tools, reports are automatically generated. View the report under the Items sub-branch of the Reports branch of the object tree.

1. Double-click on Data Points. A report preview pops up.
2. To close the report, click Close.

5.1.5 Take a snapshot

It is possible to take screen snapshots at any time in PolyWorks. It is saved to the Items sub-branch of the Reports branch of the object tree.

1. In the Main Processes toolbar, click the Reporting Processes button.
2. Click the Capture Screen as a Report Item button.

5.1.6 Reset the color mode

- Menu: View > Color > Object.

5.2 Compare using Cross-Sections

There are several ways to create Cross-Sections in IMInspect. The method used here will first set the creation method, set the specific method parameters, anchor a point on the part (point A in the snapshot) and create parallel Cross-Sections along the Y axis.

5.2.1 Display only the Data and the Reference objects

1. Select the Data and the Reference objects in the object tree.

5.2.2 Create Cross-Sections

1. In the Main Objects toolbar, click the Cross-Section Creation and Editing button.
2. Click the Create Cross-Sections button. A dialog box pops up.
3. Set Creation method to Along Standard Axis, and choose the Y axis.
4. Choose Multiple Mode.
6. Enable the *Slice whole objects* option.
7. Click *Anchor Point*.
8. Pick a point on the part (see A in previous snapshot).
   * The bounding rectangles (cutting planes) used to create the Cross-Sections are displayed in blue. See to the left in the figure below.
9. Click *Confirm*.
10. Click *Close*.

Cross-Section objects have been created and added to the object tree. See to the right in the figure below. Your Cross-Sections may differ slightly from the ones in the figure.

5.2.3 Compare using Cross-Sections

1. In the Main Processes toolbar, click the *Comparison Processes* button.
2. Click the *Compare Data to Reference at All Cross-Sections* button. A dialog box pops up.
3. Click *Continue*.

The deviations (data-to-reference) are shown as colors along the Cross-Sections, and the color scale is displayed to the right of the 3D scene.

5.2.4 View the comparison report

1. Open the Items branch of the Report branch of the object tree.
2. Double-click on *Cross-Sections*. A report preview pops up.
3. When done, click *Close*.

5.2.5 View Cross-Sections individually

1. Menu: View > Cross-Section > One by One. A dialog box appears (Dialog Zone).
2. Choose the Cross-Section to be displayed via the combo box. Also, use the UP and DOWN arrows on your keyboard to browse through the individual Cross-Sections.
3. Zoom on a Cross-Section to see its characteristics.
5.2.6 Edit the display

1. In the Cross-Section - View One by One dialog box, click Display Options. A dialog box pops up.
2. In the Show error vectors area, set Scaling factor to 3.
3. Click Apply.
4. Click Close.

The scaled error vectors let you easily find areas with high deviations. The vectors are drawn from the Reference object to the Data object. See the figure below.

5.2.7 Close the viewing dialog box

- Close the Cross-Section - View One by One dialog box.

5.2.8 Take a snapshot of all of the Cross-Sections

1. Menu: View > Pose > View -y.

5.2.9 Reset the color mode

- Menu: View > Color > Object.
5.3 Take basic measurements

There are several powerful tools in IMInspect for measuring a digitized part. Taking Interactive measurements is explained below. If you are interested in controlling Feature dimensions and GD&T (Geometric Dimensioning & Tolerancing), a separate exercise presented on page 91.

5.3.1 View only the Data object

1. Select the Data object in the object tree.
3. Menu: View > Pose > View z+.

5.3.2 Interactive measures

The most simple measurements that can be done in IMInspect are the interactive measurements. To facilitate the picking on the Data point cloud, make sure the PSIZE combo box on the Standard toolbar is set to at least 2.

5.3.3 Measure a point-to-point distance

1. In the Main Processes toolbar, click the Measurement Processes and Tools button.
2. Click the Basic Measurements button. A dialog box pops up.
3. Check Direction.
4. Press the Y button to set the measurement axis to the Y axis.
5. Click Point-to-point.
6. Click a point on the part.
7. Click a 2nd point on the part.
8. Right-click.

A Distance object has been created in the object tree, under the Measurements branch.

5.3.4 Measure a radius

1. In the Basic Measurements dialog box, click the Radius button.
2. Pick a minimum of 3 points on a circle radius.
3. Right-click when done.
4. Click Done.

A Radius object has been created in the object tree, under the Measurements branch.
6. Report results

IMInspect offers many possibilities for exporting reports. All of the available options are listed in File > Export Objects > Report Items. Formats include: Word, Excel, HTML, text, and more. Note that exports to Excel and Word require that these software be installed on your computer.

Another way of reporting information is to share the complete inspection project, within a workspace, using the IMView Project Viewer. Instructions for using the viewer are provided in a later section. See “Share the results” on page 98.

The instructions below demonstrate how to generate a formatted report automatically using the EZLayout tool. Manually creating a formatted report using EZLayout is explained in “Create Inspection Report 1” on page 101.

1. Open the Reports branch in the object tree.
2. Open the Items branch.
3. Double-click over the Header object. A dialog box appears (Dialog Zone).
4. Fill in the first three items and set all of the check boxes at the bottom of the properties sheet.
5. Click Apply.
6. Click Close.
7. Double-click over the Footer object. A dialog box appears (Dialog Zone).
8. Set all of the check boxes and add a note if you desire.
9. Click Apply.
10. Click Close.
11. Select Header, Footer, and all of the report items you wish to include in the report.
12. Right-click and select Create Auto-Formatted Report. A dialog box pops up.
14. Set Layout name to Layout1.
15. Click OK.
16. The EZLayout tool opens with your report. The first page (the Title sheet tab) contains the contents of the Header object configured above. Click the Report sheet tab at the bottom of the display area to see the contents of the report - scroll or press the PAGE DOWN key to see subsequent pages. You could now edit the report, send it to the printer, or print to PDF.
18. Click Yes to save the results.

7. Save the inspection project and exit

2. Specify a project name and a workspace location.
3. Click OK.
Exercise #2: Control Feature Dimensions and GD&T

The IMInspect module offers a Feature Controls window used to measure design or drawing specifications. From one or two Features, two main categories of measurements can be quickly performed:

- **Dimension controls**, which include:
  - properties of one Feature, such as angle, diameter, length, etc.
  - dimensions between two Features, such as distances and angles

- **True GD&T measurements** are the ones identified by GD&T symbols and defined by ASME Y14.5 M-1994 standards, which include: True Position, Parallelism, and Flatness.

The following exercise presents an example in each category of measurement.

To help you focus on the Feature Controls window here, we have prepared an IMInspect Project, `GD&T_project`, where the Data object is already aligned to the Reference object.

1. Get ready

1. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
2. In the active workspace, under the IMInspect branch, select `GD&T_project`.
3. Click “Open the IMInspect project” in the Wizard window.
4. Click Yes in the message window.
2. Create the Features

You will first create the Features necessary to perform the dimension control and then check if the geometry meets the tolerances prescribed by the GD&T symbols defined on the second image to the right.

Note that when picking Features, you may press the SPACEBAR (Interrupt mode) and then move the part, and press it again to return to the picking mode.

2.1 Display only the Reference object

1. Select the Reference object in the object tree.

2.2 Create the Datum Features

1. In the Main Objects toolbar, click the Feature Creation button.
2. Click the Create Plane Feature button. A dialog box appears (Dialog Zone).
3. Set Creation Method to Pick on NURBS.
4. Set Datum feature label to A.
5. Make sure the Status is set to Nominal.
6. Click the Pick button.
7. First click on the top side of the part to define datum A (see to the far right in the figure to the right).
8. Set Datum feature label to B.
9. Pick a second plane to define datum B (see to the left in the figure above).
10. Set Datum feature label to C.
11. Pick a third plane to define datum C (see to the left in the figure above).
12. Right-click to exit the picking mode.

2.3 Create the Features to be controlled

1. In the Main Objects toolbar, click the Feature Creation button.
2. Click the Create Cylinder Feature button. A dialog box appears (Dialog Zone).
3. Set Creation Method to Pick on NURBS.
4. Make sure the Status is set to Nominal.
5. Click the Pick button.
6. Click on a hole wall of the Reference object to extract cylinder 1, and on a second hole wall to extract cylinder 2, as shown in the figure to the right.
7. Close the dialog box when done.
2.4 Set the auto-extract parameters of the Features

1. Select cylinder 1 and cylinder 2 in the object tree.
2. Right-click and choose Properties in the shortcut menu. A dialog box appears (Dialog Zone).
3. In the Auto-extract tab, set the Fit type to Best-fit and check Reject outliers.
4. Set Plane constraint and select datum plane A in the adjacent combo box.
5. Click Apply and then click Close.
6. Select the three datum planes in the object tree and repeat steps 2, 3, and 5.

3. Control dimensions

3.1 Restore the Data object

1. Select the Data object in the object tree.

3.2 Auto-extract the measured Feature on the Data object

1. Select cylinder 1, cylinder 2, and the three planes in the object tree.

Note that you can also manually define measured Primitives by fitting Primitives on the Data object, and by probing the Primitives on a physical part.

3.3 Measure the Cylinder diameter

1. Make sure the Feature Controls window is displayed. If not, choose Window > Feature Controls.
2. Select cylinder 1 in the object tree.
3. Check that the Dimensions area of the Feature Controls window is displayed. If needed, press the Dimensions button.
4. In the Dimensions area of the Feature Controls window, check the Diameter item.
5. Set High Tol to 0.01 and Low Tol to -0.01. Press the ENTER key.

The deviation of the diameter between the nominal (Reference) and the measured (Data) cylinders is calculated and displayed in the Feature Controls window and in the Feature's annotation.
3.4 Control the dimension between 2 Features

1. In the Main Objects toolbar, click the Feature Creation button.
2. Click the Create Distance Feature button. A dialog box appears (Dialog Zone).
3. Set Feature 1 to cylinder 1.
4. Set Feature 2 to cylinder 2.
5. Click Create. The Feature distance 1 is created.
6. Click Close.
7. Select distance 1 in the object tree.
8. Check that the Dimensions area of the Feature Controls window is displayed. If needed, press the Dimensions button.
10. Set High Tol to 0.01 and Low Tol to -0.01.
11. Press the ENTER key.

4. Perform GD&T controls

The second part of this exercise will show you how to measure the Position of a hole; see the figure to the right.

4.1 Control the Position of a hole

1. Select the Reference object, the three datum Planes, and the two Cylinders in the object tree.
3. Make sure the Feature Controls window is displayed. If not, choose Window > Feature Controls.
4. Select cylinder 1 in the object tree.
5. In the Feature Controls window, click the GD&T button to show this section.
6. The feature control frame to create is shown in the figure to the right. See the figure that follows to help you create the feature control frame - do the four steps show in the figure.
4.2 Create and view a Feature report

1. Select cylinder 1 and distance 1 in the object tree.
2. Right-click and choose Report.
3. In the Items sub-branch of the Reports branch in the object tree, double-click on Feature.
4. Click Close when done.

5. Save and exit

1. Menu: File > Save Project.
Exercise #3: Using an automated inspection project

IMInspect features a Macro Script Editor for recording your commands to a macro script, and a basic programming language called the Macro Script Control Language (MSCL) to enhance the recorded commands by adding controls, such as IF and WHILE commands, which allow conditional execution and loops. You may even call other macro scripts from a main macro script, permitting efficient, modular macro script files.

In this exercise, you will load an IMInspect Project that uses macro scripts, called from buttons on a custom toolbar. The macro scripts will allow you to perform alignment (A), measurement by comparison (C), measurement (M), and report (R) operations. A message window pops up after each operation to indicate that it is finished; press the OK button to close the window. Note that after each macro you can move the 3D scene (rotate, translate, zoom) in order to better view the results.

If an operation does not perform correctly, you may press the first button, Reset (RE), to reset correct initial conditions to assure that all of the macro scripts will work correctly, and then start over again. The last button (ALL) lets you perform all of the operations, in order, one after the other, demonstrating the concepts of automating an inspection project and modular programming.

While the creation of macro scripts is not within the scope of this document, a simple exercise is provided on page 112 if you are interested. For complete information on creating macro scripts and the MSCL programming language, see the Macro and SDK Reference Guide, which is available from the Workspace Manager’s Help menu.

1. Get ready

Open the IMInspect Project

1. Make sure that the correct visual layout is specified in the Workspace Manager: Window > Visual Layout > Manufacturing - Beginner.
2. In the active workspace, select Automatic_inspection_project.
3. In the Wizard window, click “Open the IMInspect project”.
4. Click Yes when asked if you want to use this project’s own configuration.

Save the previous layout

2. Specify a file name and location.
3. Click Save.

Load a visual layout

2. Select automatic_inspection_project_layout.vlt.
3. Click Open.
2. Perform the automatic operations

2.1 Reset the project

- Click \( \text{Re.} \) (on the toolbar to the right of the 3D scene).

2.2 Perform Data-to-Reference alignment operations

1. Click \( \text{A1} \) (do a best-fit alignment).
2. Click \( \text{A2} \) (do a RPS alignment; for more information, see page 116).
3. Click \( \text{A3} \) (do a datum-based alignment; for more information, see page 117).

2.3 Perform comparison operations (specific kind of measurement)

1. Click \( \text{C1} \) (measure globally using all data points).
2. Click \( \text{C2} \) (measure locally using comparison points; for more information, see page 117).
3. Click \( \text{C3} \) (measure locally using Cross-Sections).

2.4 Perform other measurement operations

1. Click \( \text{M1} \) (measure using soft caliper gauges; for more information, see page 120).
2. Click \( \text{M2} \) (measure profiles using profile gauges; for more information, see page 120).
3. Click \( \text{M3} \) (perform GD&T measurements).

2.5 Export reports to Microsoft Excel

The macro scripts create reports and snapshots of the 3D scene that are under the Items sub-branch of the Reports branch in the object tree. The next macro exports all of these items to an Excel spreadsheet (must have Excel on your system), which is one of several standard outputs.

- Click \( \text{Re.} \).

2.6 Redo all of the operations automatically

- Click \( \text{All} \) (calls each of the other buttons in turn).
B. Share the results

it is essential to be able to share an IMInspect inspection report with colleagues, suppliers, etc. IMInspect projects can be opened and viewed using PolyWorks/IMView, InnovMetric Software’s free IMInspect Project and polygonal model viewer. With IMView, you can:

- View comparison results by category (e.g., Cross-Sections) and by item in a category (e.g., Cross-Section 1).
- Create new Cross-Sections manually (cannot be compared or compensated).
- Take new interactive measurements (e.g., angle, distance, length).
- See the object tree.
- Create new reports.
- Select and export objects.

Note that while you may create some new items, no changes can be saved to the IMInspect Project being viewed. Any new items must therefore be exported before closing the project.

Note also that IMView is for viewing, and consequently you cannot perform any alignment or comparison operations, or measure using soft gauges or Feature objects, and IMView does not feature a Macro Script Editor for macro scripts.

Open a PolyWorks workspace

The Workspace Manager should be open and the PolyWorks_processes.pwk workspace open in the Workspaces area.

1. Select IMInspect_Project_for_IMView in the active workspace.
2. In the Wizard window, click “View the IMInspect project”.

**IMView basics**

This section presents module-specific basics. The exercise begins on page 100.

**The basic interface layout**

The IMView default interface layout features an object tree and a 3D scene. The menus are very similar to ones in the IMInspect module. When IMView detects that the IMInspect Project contains inspection results, the object tree is hidden and the first inspection result is displayed.

![IMView interface layout](image)

The IMView module shown above has an IMInspect Project loaded. IMView makes a list of the categories of objects and offers them, one by one, through the first combo box (list of categories) on the Standard toolbar. You may navigate to a different category using the Previous and Next buttons to the left of the combo box, or by selecting in the combo box.

For each category of object, IMView uses a filter that specifies a display mode, controls the display of objects in the 3D scene, and offers contextual toolbar buttons. If the category of objects has comparison results associated with it, then the color map is displayed to the right of the 3D scene.

If an inspection results category contains more than one item, you may use the second combo box to display a particular item, or the preceding Previous and Next arrows to cycle through the items in the list.

To view the object tree of an IMInspect Project, press the second button on the toolbar. The category combo box is set to Whole Project and the navigation combo boxes are removed from the toolbar. You now control the object display.
**Exercise #1: View an inspection project**

In this exercise, you will view the contents of an IMInspect report, take new measurements, create new reports, and export them. Note that new objects cannot be saved to the IMInspect Project, but they can be exported, with the exception of Measurement objects.

1. **View the categories of objects and their comparison results**

Most operations in IMView are done with the object tree hidden. If it is displayed, please hide it now by pressing the button shown to the left.

- Using the two combo boxes on the Standard toolbar, cycle through categories of objects and items in each category. This is a fast and easy way to see just certain categories of objects.

2. **Take new measurements**

IMView gives you the opportunity of creating new measurements. You may also create new Cross-Sections of Data/Reference objects in the 3D scene to extract the shape of the objects.

2.1 **Take new interactive measurements on the Data object**

1. In the first navigation combo box on the Standard toolbar, select Data to Ref Cmps.
2. Hide the Reference object by pressing the Standard toolbar button shown to the left.
4. Click Point-to-point.
5. Click two locations on the Data object.
6. Right-click to finish.
7. Click Done.
8. Display the Reference object by pressing the Standard toolbar button shown to the left.

A first Measurement object has been created under the Measurements branch in the object tree. As a result, the Measurements category is added to the Categories combo box.

2.2 **View/keep a Cross-Section of the 3D scene**

1. Menu: View > Cross-Section > Of the 3D scene. A dialog box pops up.
2. Click Anchor Line.
3. Click once to each side of the visible objects. You see a clipping range to each side of the Cross-Section. You can enter a larger value for the Clipping range in the Options tab and click Apply, or set options in the Clipping mode combo box and click Apply after each selection.
4. To create a Cross-Section, click the Plane tab and click Create Cross-Section.
5. Click Close.

Note: the created Cross-Section may not be visible in the 3D scene if the current navigation category does not allow the display of Cross-Sections.
3. Create new report items

In IMView you may create new report items (in the Items sub-branch of the Reports branch) and you may export them. Several options for creating new report items can be found under the Report menu.

3.1 Create snapshots of all Cross-Sections

In this step, you will generate snapshots of Cross-Sections (IMView automatically displays the Cross-Sections and the objects anchored to them (e.g., calipers)).

1. Show the object tree by pressing the button shown to the left.
2. Make sure the Cross-Sections under the Cross-Sections branch of the object tree are visible (middle-click on an object in the object tree to toggle its visibility status).

New report items are created under the Items branch of the Report branch of the object tree. You can double-click on a snapshot item to see its contents.

4. Create a new formatted report

In the previous exercise, you learned that it is possible to create new report items. You can incorporate certain report items into a new formatted report. PolyWorks has a powerful tool for creating formatted reports called EZLayout. Formatted reports can be saved to the inspection project and exported to HTML and PDF formats, or as images (one image per page of report). A formatted report consist of a layout and any number of text, image, and report items.

If you want to keep the layout in order to use it to create other formatted reports, it can be exported to a standalone location and then imported into another IMInspect Project.

4.1 Create Inspection Report 1

The following exercises will show you how to create a simple formatted report, print it, and export the formatted report and its layout to PDF format.

4.1.1 Create a formatted report

2. Set Report Name to Inspection report 1.
4. Click OK.
The interface for the EZLayout tool will pop-up. It is divided into an object area to the left and a
drawing area to the right. The object area is divided into three object tree areas:

<table>
<thead>
<tr>
<th>Area</th>
<th>Description</th>
</tr>
</thead>
</table>
| Layout Structure      | contains the sheets in the currently selected report; note the following:  
• a sheet describes a particular part of a report such as the introduction, chapters, the conclusion, etc.; it may contain fixed items (text created by you and imported images) or variable items (text, images, reports) that use the content of IMInspect items  
• a sheet starts off with only one page but as you add items to it pages are added automatically; a sheet can have any number of pages  
• a report can have any number of sheets  
• only one sheet can be active at a time; you work in the active sheet  
• the background sheet contains items common to all of the other sheets (e.g., header and footer, images, page numbers) |
| Formatted Reports     | contains all of the reports in the project associated with the layout                                                                                                                                        |
| IMInspect Items       | contains all of the report items available in the IMInspect Project                                                                                                                                          |

### 4.1.2 Add an image to sheet 1

1. In the IMInspect Items section, select the IM_logo snapshot.  
2. Drag it to the left top corner of sheet 1.

This item is now part of sheet 1. It has been added to the Layout Structure object tree under the sheet 1 branch.

### 4.1.3 Place the image on the background sheet

1. Click on the item you just inserted in sheet 1.  
3. Check On background sheet.  
4. Check Repeated on all pages.  
5. Click Apply.  
6. Click Close.

Items cannot be added directly to the background sheet using the drawing area. It must be done by changing the properties of an item on a sheet, as was done here. This item is removed from sheet 1 and transferred to the background sheet. It is displayed in the Layout Structure object tree under the background sheet branch.

Repeating items on all pages will automatically place the item at the same place on every page of every sheet.
4.1.4 Add fixed text to sheet 1

1. Select sheet 1 in the Layout Structure object tree.
2. Menu: Item > Create > Text Field (Fixed).
3. A text box appears. Drag it to be beside the background image and click to anchor its position.
4. In the text box, type INSPECTION REPORT.
5. Resize the text box to fit the text by dragging the handles on the sides of the text box.

This text field is *fixed*. Its contents will appear as such in the report.

4.1.5 Format the text

1. Double-click in the text field that was added in the previous step.
2. Highlight all of the text.
3. Right-click over the selection. A dialog box pops up.
5. Set Font to Arial.
6. Set Style to Bold.
7. Click OK.
8. Press ESC to exit the editing mode.
9. Resize the text box to fit the text by dragging the handles on the sides of the text box.

4.1.6 Add a table item

You will add a table item to sheet 1. Then, you will remove some information currently displayed in the report by modifying its template.

1. Click on the 1st table in the IMInspect Items object tree (*Data Points*) and drag it on sheet 1.
2. Modify the template of the table item:
   - Select the table in the sheet.
   - Right-click over it and choose Properties. A dialog box pops up.
   - Click Edit Privately.
   - Select Offset and click Ignore.
   - Select Points within +/- (6*StdDev) and click Ignore.
   - Select Points within +/- (5*StdDev) and click Ignore.
   - Click Save.
   - Click Close.
3. Click on the 2nd item in the IMInspect items object tree and drag it to a location on sheet 1.
4. Repeat the operation for any other items.

Sheet 1 may now have more than one page. A sheet can grow horizontally (columns) and vertically (rows), depending on the shape of the items being added to it. You can specify the page order for printing to be by column or by row (*Edit > Layout Properties*).

4.1.7 Save the formatted report and the layout to the project

- Menu: File > Save Layout and Reports.
4.1.8 Print the formatted report


4.1.9 Export the formatted report

1. Menu: File > Export Report > to PDF. A file browser pops up.
2. Specify a file name and location.
3. Click Save.

4.1.10 Exit EZLayout

- Menu: File > Exit.

5. Export objects

The Export Objects item of the File menu offers almost all of the export options available in IMInspect. The Export submenu of the object tree shortcut menu for selected objects offers only those export operations available for the selected objects.

5.1 Export selected report items

1. Select the desired Cross-Sections in the object tree.
2. Right-click and choose Export > (item).
3. Select the new snapshot report items in the object tree.
4. Right-click and choose Export > (item).

5.2 Export layouts

You may export the layout to disk in order to reuse it later in another inspection project.

5.2.1 Export the layout

1. Select a layout in the object tree.
2. Right-click and choose Export. A file browser pops up.
3. Specify a file name and location.
4. Click Save.

An exported layout is saved as a file and a folder.

6. Exit IMView

- Menu: File > Exit.
Additional Information

This section presents additional information for each of the main PolyWorks modules – IMAlign, IMEdit, and IMInspect.

1. IMAlign – More information and other tools

The comments below refer to certain parts of the section on Acquiring Data. In the introduction to the section on alignment, on page 27, you learned that IMAlign converts scans to 3D Images. The scans used in the exercises in the Acquiring Data section were automatically converted to 3D Image format. IMAlign also offers other scan-to-3D Image conversion processes:

<table>
<thead>
<tr>
<th>Digitizer type</th>
<th>Conversion process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Scanner</td>
<td>A scan that typically contains a large number of overlapping “passes”. The <em>Point Cloud Organizer</em> tool automatically pops up. You specify a few parameters and this tool can automatically convert each pass in a line scan to a 3D Image.</td>
</tr>
<tr>
<td>Spherical Grid</td>
<td>Large surveying datasets that cover thousands of square meters; each scan is partially or completely spherical. The <em>Subdivide by Range</em> tool allows you to specify base 3D Image creation parameters that are adjusted with respect to their distance from the origin. A large number of 3D Images may be created. They become children of a composite 3D Image.</td>
</tr>
<tr>
<td>Unorganized Point Cloud</td>
<td>A point cloud with points not necessarily captured with respect to a viewing plane and with insufficient organization for conversion to 3D Image format. Using the <em>Point Cloud Organizer</em>, manually delimit a subset of points using a viewing plane, and specify a few 3D Image creation parameters; each subset is converted to a 3D Image. Note: you should ensure overlap between subsets.</td>
</tr>
</tbody>
</table>

In the exercises, 3D Images were aligned using the 1 Point Pair Alignment and the Auto-align techniques. IMAlign offers additional alignment techniques:

<table>
<thead>
<tr>
<th>Alignment Techniques</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>N Point Pairs Alignment</td>
<td>For each new 3D Image, click three or more pairs of matching points, perform a best-fit alignment, and lock the new 3D Image.</td>
</tr>
<tr>
<td>Manual Alignment</td>
<td>Apply user-specified translations and rotations via a dialog box.</td>
</tr>
</tbody>
</table>
Once the 3D Images are aligned, they are analyzed for alignment quality (page 35). Analyzing the deviations by comparing 3D Images may be done using three techniques:

<table>
<thead>
<tr>
<th>Comparison Techniques</th>
<th>Illustration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Points to Images</strong></td>
<td><img src="image" alt="Points to Images Illustration" /></td>
</tr>
<tr>
<td>Computes the distance (error) from each point to its farthest 3D Image.</td>
<td></td>
</tr>
</tbody>
</table>

| **Individual Points**         | ![Individual Points Illustration](image) |
| Computes the displacement distance related to each point from initial to final alignment position. |

| **High to Low Image**         | ![High to Low Image Illustration](image) |
| Computes the maximum distance between all 3D Images by choosing the highest and the lowest 3D Image for a local area. |
### 2. IMEdit – Other tools

The tables that follow illustrate IMEdit tools not demonstrated in the Reverse-Engineering section of this guide.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Illustration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Boolean operations</strong></td>
<td><img src="image1" alt="Illustration" /> <img src="image2" alt="Illustration" /></td>
</tr>
</tbody>
</table>

Boolean operations let you intersect a model (group of triangles) with another model (group of triangles), creating distinct regions.

Then, select regions (displayed here by color) to obtain an assembled model containing the triangles that you want to keep.

The final model, constructed from two intersecting models.
### Tool

<table>
<thead>
<tr>
<th><strong>Fillet</strong></th>
<th><strong>Illustration</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Fillet a polygonal model based on a rolling-ball algorithm.</td>
<td><img src="image1" alt="before filleting" /> <img src="image2" alt="after filleting" /></td>
</tr>
</tbody>
</table>

**before filleting**

**after filleting**

<table>
<thead>
<tr>
<th><strong>Mirror</strong></th>
<th><strong>Illustration</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>The mirror tool allows you to duplicate an object or part of an object by mirroring it with respect to a plane. This tool can be used to speed up the modeling process for symmetrical objects.</td>
<td><img src="image3" alt="mirror illustration" /></td>
</tr>
</tbody>
</table>

### IMEdit – Other tools

**Slice with a plane**

This tool lets you slice a polygonal surface with a plane.

**Offset**

This tool lets you create a copy of a polygonal surface or part of that surface at a specified distance (offset distance) from the original surface. This tool is useful to create thin shell objects that can be reproduced by a rapid prototyping device.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Illustration</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Reconstruct</strong></td>
<td>a) Identify the areas to reconstruct</td>
</tr>
<tr>
<td></td>
<td>b) Select the elements</td>
</tr>
<tr>
<td></td>
<td>c) Click the <em>Reconstruct Mesh</em> button</td>
</tr>
<tr>
<td></td>
<td>d) The surface has successfully been reconstructed</td>
</tr>
</tbody>
</table>
3. IMEdit – IMCompress parameters

Reducing or compressing the mesh is an operation where some triangles are removed from the mesh without changing the accuracy of the overall model. During this operation, triangles are removed over flat areas and small triangles are kept in the highly curved/detailed areas.

You can reduce part or all of the polygonal mesh. Reduction is normally done once the editing work is finished.

Specify a reduction level in one of four ways:

- Specify a target number of triangles in the **Number of triangles** text box.
- Specify a reduction percentage on the number of triangles in the **Reduction percentage** spin box. A 0% reduction percentage preserves the current triangulation, while a 100% percentage guarantees maximum reduction of the selected area.
- Specify a relative 3D tolerance in the **Relative tolerance** text box, as a percentage of the largest side of the model’s bounding box.
- Specify a 3D tolerance in model units in the **Tolerance** text box. This is a maximum absolute distance in model units that a surface area can be lowered by removing a vertex and retriangulating.

In addition, the dialog box provides a **Max edge length** combo box that allows you to set a maximum triangle edge length, which is set to **Not constrained** by default. To specify a maximum edge length, enter a value in the combo box.

Finally, the dialog box provides a **Max dihedral angle** text box for detecting sharp edges and corners prior to compression. Sharp edges and corners will then be preserved by the polygon reduction algorithm. Edges are reduced along their length using the same tolerance applied to the surface triangulation reduction.

Reduction is performed by pressing the **Apply** button. It should be noted that IMEdit preserves the boundary of the selected area throughout the reduction process.
4. IMlnspect – Macro script basics

This section introduces you to the Macro Script Editor to help understand the macro scripts that were executed in the automatic inspection project (page 96). A macro script always begins with the `version` command, contains module commands that perform module operations, and often includes MSCL programming language commands to control macro script execution.

4.1 Get ready

Open an IMlnspect Project

1. In the active workspace, select `Automatic_inspection_project`.
2. In the Wizard window, click “Open the IMlnspect project”.
3. Click Yes when asked if you want to use this project’s own configuration.

Save the previous layout

2. Specify a file name and location.
3. Click Save.

Load a visual layout

2. Select `automatic_inspection_project_layout.vlt`.
3. Click Open.
4.2 Open a macro script

1. Right-click over the M1 button and select *Edit Macro Script* in the shortcut menu.
2. The Macro Script Editor opens with the macro script *Demo block Calipers.macro* loaded.

The *Macro Script Editor* window is shown in the figure on the top of the next page. The *Command History* window (select *Window > Command History*) is also shown below as it is useful when developing macro scripts.

![Macro Script Editor](image)

The *editor* window lets you construct a macro script. For example, you can record your actions and paste them to this window. Or, you can use the TAB key to build commands one at a time (see exercise below). You can also copy commands from the *Command History* window and the Command Line area and paste them in the editor window.

Concerning the Command History window:
- It displays the commands that you perform while using the module, which helps associate a command with an action.
- The *command line* at the bottom lets you execute commands directly; you may then copy them into a macro script.
4.3 Use the Macro Script Editor

1. In IMInspect’s main menu, choose View > Axes > Origin. The command is performed by IMInspect. It also appears in the Command History window, showing the command name.

2. In the Macro Script Editor window:
   - Menu: File > New.
   - Type “V” and press the TAB key. The command is completed: VIEW appears (the only command that begins with the letter “V”).
   - Press the TAB key again and see all of the possible keywords that can follow VIEW. Double-click on VISIBILITY.
   - Press the TAB key again and double-click on OBJECTS.
   - Press the TAB key again and double-click on HIDE.
   - Press the TAB key again and note the syntax window that appears when a valid command has been constructed.
   - On the next line type MACRO PAUSE.
   - On the next line type VIEW VISIBILITY OBJECTS RESTORE.
   - Menu: File > Save. In the browser, provide the name Test and click Save.
   - Menu: Macro > Check Syntax. If no comment appears, the syntax is correct.
   - Menu: Macro > Run. The macro script is executed (see the Command History window) and the objects are hidden, then click OK in the message window and the objects are restored.

3. In the Macro Script Editor, choose Help > HTML Command Reference. The MSCL commands can be found by browsing under LANGUAGE, and the module’s commands can be found by browsing under the main menu items. This help provides syntax information for complete commands. When you are finished browsing, close the browser.

4. Close the Macro Script Editor window.

The Macro Script Editor also offers a recorder that records your operations. You may then manually add other module and programming language commands, and test and save the macro script.

4.4 Load the previous layout

2. Click No in the message window.
3. Select your previous layout and click Open.
4. Click No in the message window.

4.5 Exit IMInspect without saving changes to the inspection project

- Menu: File > Exit, and click No in the message window.
5. IMInspect – Other tools

In the tables that follow, learn about other alignment, comparison, and measurement techniques offered by IMInspect but not presented in the Inspection section of this guide.

<table>
<thead>
<tr>
<th>1 - Other Data-to-Reference alignment techniques available in IMInspect</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Manual Alignment</strong></td>
</tr>
<tr>
<td>An interactive mode for manually applying user-defined translations and rotations. For example, moving an object 10 mm in the Z-axis direction.</td>
</tr>
<tr>
<td><img src="image1" alt="Manual Alignment Diagram" /></td>
</tr>
<tr>
<td><strong>N Pairs of Center Points</strong></td>
</tr>
<tr>
<td>Alignment performed using pairs of primitive center points. For example, aligning a part using 4 circle centers.</td>
</tr>
<tr>
<td><img src="image2" alt="N Pairs of Center Points Diagram" /></td>
</tr>
</tbody>
</table>
1 - Other Data-to-Reference alignment techniques available in IMInspect

3 Perpendicular Planes
Alignment performed by matching 3 perpendicular planes from the Data object to 3 other planes on the Reference object.

Reference Points Alignment (RPS)
Alignment performed by matching reference points on the Reference object with Primitives on the Data object. It is also possible to match Reference points directly to the Data object. Excellent for sheet metal or casting part.
1 - Other Data-to-Reference alignment techniques available in IMInspect

**Datum Matrix**
Alignment performed using a Datum sequence. Typically used for GD&T tolerance measurement. For example, aligning a part using Datum planes A, B and C for a GD&T measurement.

2 - Other measurement techniques available in IMInspect

**Comparison Points**
Computes the Data-to-Reference deviation on specific points on the part.

**Compare Data to Primitive**
Computes the deviation between the Data object and a selected Primitive.
### 2 - Other measurement techniques available in IMInspect

<table>
<thead>
<tr>
<th>Compare Data to Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computes the deviation between two Data objects. Typically used for part-to-part inspection.</td>
</tr>
</tbody>
</table>

**BEFORE**

![Before Image](image1)

**AFTER**

![After Image](image2)

<table>
<thead>
<tr>
<th>Compare Primitive to Primitive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computes deviations between two primitives. For example, the angle between two planes.</td>
</tr>
</tbody>
</table>

![Comparing Planes](image3)
### Multiple Data Variability

Computes the variation between multiple scans of the same part, using an "average" part computed on the fly using all of the scans in the same project. Manufacturing variability can easily be verified using this feature.
### 3 - Other measurement tools available in IMInspect

<table>
<thead>
<tr>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fillet radii</strong></td>
<td>Tool for automatically detecting and measuring fillets on a model. For example, this tool can automatically inspect all of the fillets on a sheet metal die.</td>
</tr>
<tr>
<td><strong>Surface-to-plane volume</strong></td>
<td>Tool for measuring the volume between a surface and a plane.</td>
</tr>
<tr>
<td><strong>Thickness</strong></td>
<td>Tool for automatically measuring the thickness of thin walls on a part. The results are displayed using a color map.</td>
</tr>
<tr>
<td><strong>Caliper Gauge</strong></td>
<td>Tool for measuring distances between two surfaces, such as width, length, or thickness.</td>
</tr>
</tbody>
</table>
### 3 - Other measurement tools available in IMInspect

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Flush &amp; Gap Gauge</strong></td>
<td>Programmable tool for measuring the spacing separating two assembled parts. For example, the gap between a car door and a fender panel.</td>
</tr>
<tr>
<td><strong>Profile Gauge</strong></td>
<td>Tool for detecting and measuring fillet radii on a profile. Can also measures various distances along that profile.</td>
</tr>
<tr>
<td><strong>Airfoil Gauge</strong></td>
<td>Tool for performing airfoil specific measurements like the Leading Edge (LE) and Trailing Edge (TE) radius and thicknesses at various points. Computing chord length, maximum thickness, stagger angle, both Aerodynamics and Tangential types of Gauges are available.</td>
</tr>
</tbody>
</table>